summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-11-19 16:09:44 -0400
committerJoey Hess <joey@kitenet.net>2013-11-19 16:09:44 -0400
commite011fd72ef69dbbaa4f63bfd61564e0918cb3e22 (patch)
treea371af17996f35ffa2d4bfa66c09a06124c40539 /Makefile
parentd39035d46df979abcf34d1411f96b5a70bd2d93c (diff)
downloadgit-repair-e011fd72ef69dbbaa4f63bfd61564e0918cb3e22.tar.gz
initial work on git repository destroyer
I suspect this might sometimes corrupt the **source** repo, so use with caution!
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 07df05d..90274ac 100644
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,7 @@ CABAL?=cabal # set to "./Setup" if you lack a cabal program
build: Build/SysConfig.hs
$(CABAL) build
ln -sf dist/build/git-repair/git-repair git-repair
+ ln -sf dist/build/test-runner/test-runner test-runner
@$(MAKE) tags >/dev/null 2>&1 &
Build/SysConfig.hs: configure.hs Build/TestConfig.hs Build/Configure.hs
@@ -17,9 +18,10 @@ install: build
install -m 0644 git-repair.1 $(DESTDIR)$(PREFIX)/share/man/man1
clean:
- rm -rf git-repair dist configure Build/SysConfig.hs Setup tags
- find -name \*.o -exec rm {} \;
- find -name \*.hi -exec rm {} \;
+ rm -rf git-repair test-runner test-runner.log \
+ dist configure Build/SysConfig.hs Setup tags
+ find . -name \*.o -exec rm {} \;
+ find . -name \*.hi -exec rm {} \;
# Upload to hackage.
hackage: clean