summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-11-21 02:20:19 -0400
committerJoey Hess <joey@kitenet.net>2013-11-21 02:20:19 -0400
commite38c59dfde89f15c61b4073dcd19b53dfe440e74 (patch)
tree1f6d32f1b125f4c21232eb8c63748572f59c4c7a /Makefile
parent897f030f68ff847c03494fbdd4104d1f8dfad9fe (diff)
downloadgit-repair-e38c59dfde89f15c61b4073dcd19b53dfe440e74.tar.gz
combine test program into git-repair
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 756f686..ebbecdf 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,6 @@ CABAL?=cabal # set to "./Setup" if you lack a cabal program
build: Build/SysConfig.hs
$(CABAL) build
ln -sf dist/build/git-repair/git-repair git-repair
- ln -sf dist/build/git-repair-test/git-repair-test git-repair-test
@$(MAKE) tags >/dev/null 2>&1 &
Build/SysConfig.hs: configure.hs Build/TestConfig.hs Build/Configure.hs
@@ -18,7 +17,7 @@ install: build
install -m 0644 git-repair.1 $(DESTDIR)$(PREFIX)/share/man/man1
clean:
- rm -rf git-repair git-repair-test git-repair-test.log \
+ rm -rf git-repair git-repair-test.log \
dist configure Build/SysConfig.hs Setup tags
find . -name \*.o -exec rm {} \;
find . -name \*.hi -exec rm {} \;