summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2014-07-21 16:37:31 -0400
committerJoey Hess <joey@kitenet.net>2014-07-21 16:37:31 -0400
commite339c36e79fe52a89f5125544917d119566d5fbb (patch)
tree6a021cc3fdba8dbf3722514f801a2b39254b1745 /Makefile
parentdd2fde6c81b1144fe82e0c63df7b38fd17ab884a (diff)
downloadgit-repair-e339c36e79fe52a89f5125544917d119566d5fbb.tar.gz
update tags rule
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ebbecdf..42848b7 100644
--- a/Makefile
+++ b/Makefile
@@ -29,6 +29,6 @@ hackage: clean
# hothasktags chokes on some template haskell etc, so ignore errors
tags:
- find . | grep -v /.git/ | grep -v /tmp/ | grep -v /dist/ | grep -v /doc/ | egrep '\.hs$$' | xargs hothasktags > tags 2>/dev/null
+ (for f in $$(find . | grep -v /.git/ | grep -v /tmp/ | grep -v /dist/ | grep -v /doc/ | egrep '\.hs$$'); do hothasktags -c --cpp -c -traditional -c --include=dist/build/autogen/cabal_macros.h $$f; done) 2>/dev/null | sort > tags
.PHONY: tags