summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--git-repair-test.hs (renamed from test-runner.hs)6
-rw-r--r--git-repair.cabal6
3 files changed, 8 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index b650760..756f686 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@ CABAL?=cabal # set to "./Setup" if you lack a cabal program
build: Build/SysConfig.hs
$(CABAL) build
ln -sf dist/build/git-repair/git-repair git-repair
- ln -sf dist/build/test-runner/test-runner test-runner
+ ln -sf dist/build/git-repair-test/git-repair-test git-repair-test
@$(MAKE) tags >/dev/null 2>&1 &
Build/SysConfig.hs: configure.hs Build/TestConfig.hs Build/Configure.hs
@@ -18,7 +18,7 @@ install: build
install -m 0644 git-repair.1 $(DESTDIR)$(PREFIX)/share/man/man1
clean:
- rm -rf git-repair test-runner test-runner.log \
+ rm -rf git-repair git-repair-test git-repair-test.log \
dist configure Build/SysConfig.hs Setup tags
find . -name \*.o -exec rm {} \;
find . -name \*.hi -exec rm {} \;
diff --git a/test-runner.hs b/git-repair-test.hs
index 56b118e..8256d31 100644
--- a/test-runner.hs
+++ b/git-repair-test.hs
@@ -34,7 +34,7 @@ parseSettings = Settings
)
<*> switch
( long "retry"
- <> help "Retry tests in test-runner.log"
+ <> help "Retry tests in git-repair-test.log"
)
<*> switch
( long "stop-on-failure"
@@ -53,7 +53,7 @@ main = execParser opts >>= run
where
opts = info (helper <*> parseSettings) desc
desc = fullDesc
- <> header "test-runner - test command in corrupted git repository"
+ <> header "git-repair-test - test git-repair"
run :: Settings -> IO ()
run settings
@@ -123,4 +123,4 @@ logDamage :: [Git.Destroyer.Damage] -> IO ()
logDamage damage = appendFile logFile $ show damage ++ "\n"
logFile :: FilePath
-logFile = "test-runner.log"
+logFile = "git-repair-test.log"
diff --git a/git-repair.cabal b/git-repair.cabal
index 77150ee..ff5e964 100644
--- a/git-repair.cabal
+++ b/git-repair.cabal
@@ -1,5 +1,5 @@
Name: git-repair
-Version: 1.20131118
+Version: 1.20131119
Cabal-Version: >= 1.6
License: GPL
Maintainer: Joey Hess <joey@kitenet.net>
@@ -28,8 +28,8 @@ Executable git-repair
if (! os(windows))
Build-Depends: unix
-Executable test-runner
- Main-Is: test-runner.hs
+Executable git-repair-test
+ Main-Is: git-repair-test.hs
GHC-Options: -Wall -threaded
Build-Depends: MissingH, hslogger, directory, filepath, containers, mtl,
network, extensible-exceptions, unix-compat, bytestring,