summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Kahn Gillmor <dkg@fifthhorseman.net>2019-11-25 01:53:57 -0500
committerSean Whitton <spwhitton@spwhitton.name>2019-11-25 07:46:31 -0700
commitd25fe196a3cb2070b7b4939de292074448716999 (patch)
tree729cb2bdb8ce970772d1ce3f2b1bef55dc7a7a09
parentb80164cb3c3e713a68c184096ec98293890a5ba9 (diff)
downloadmailscripts-d25fe196a3cb2070b7b4939de292074448716999.tar.gz
email-print-mime-structure: Verify Python type annotations
Signed-off-by: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-rw-r--r--Makefile3
-rw-r--r--debian/control1
2 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index de2a784..af30616 100644
--- a/Makefile
+++ b/Makefile
@@ -9,10 +9,11 @@ all: $(MANPAGES) $(COMPLETIONS)
check:
./tests/email-print-mime-structure.sh
+ mypy --strict ./email-print-mime-structure
clean:
rm -f $(MANPAGES)
- rm -rf completions
+ rm -rf completions .mypy_cache
%.1: %.1.pod
pod2man --section=1 --date="Debian Project" --center="User Commands" \
diff --git a/debian/control b/debian/control
index 0ef1ece..2e96d3e 100644
--- a/debian/control
+++ b/debian/control
@@ -10,6 +10,7 @@ Build-Depends:
diffutils <!nocheck>,
gpg <!nocheck>,
gpg-agent <!nocheck>,
+ mypy <!nocheck>,
perl,
python3 <!nocheck>,
python3-argcomplete,