summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2021-01-19 16:13:00 -0700
committerSean Whitton <spwhitton@spwhitton.name>2021-01-19 16:13:10 -0700
commitd402aaa1e1a507e6145ef9c1a7c1957496e3cdc3 (patch)
tree19c7ad2d76b24c0ae67a5587b3f156ae0b6ff2a1
parentbcae92b442ab909e633a838d5f83bcf8185b2784 (diff)
downloadmailscripts-d402aaa1e1a507e6145ef9c1a7c1957496e3cdc3.tar.gz
Use 'cl-case' not 'case' and require cl-lib
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
-rw-r--r--debian/changelog3
-rw-r--r--mailscripts.el3
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 294857a..050458b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,7 +5,8 @@ mailscripts (0.22-1) UNRELEASED; urgency=medium
- add new defcustom, mailscripts-project-library
- replace *-projectile commands with new *-to-project commands, which
support both Projectile and project.el for choosing from known
- projects.
+ projects
+ - Use 'cl-case' not 'case' and require cl-lib.
-- Sean Whitton <spwhitton@spwhitton.name> Tue, 21 Jul 2020 21:22:39 -0700
diff --git a/mailscripts.el b/mailscripts.el
index 703f86e..aafcf15 100644
--- a/mailscripts.el
+++ b/mailscripts.el
@@ -21,6 +21,7 @@
;;; Code:
+(require 'cl-lib)
(require 'notmuch)
(require 'thingatpt)
@@ -202,7 +203,7 @@ git-format-patch(1)."
branch))))))
(defun mailscripts--project-repo-and-branch (f &rest args)
- (let ((repo (case mailscripts-project-library
+ (let ((repo (cl-case mailscripts-project-library
('project
(require 'project)
(project-prompt-project-dir))