summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-07-24 11:49:34 +0800
committerSean Whitton <spwhitton@spwhitton.name>2018-07-24 11:49:34 +0800
commit210c5001675144b7ae382fed6cac7a227d35e420 (patch)
tree1941e86199558d8f515b33f4ceb3a1984a9572be
parent02b8bbe05c3d105b7faae91d389de4709efa2164 (diff)
downloadmailscripts-210c5001675144b7ae382fed6cac7a227d35e420.tar.gz
build and install a manpage for mdmv
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
-rw-r--r--Makefile8
-rw-r--r--debian/control2
-rw-r--r--debian/manpages1
-rw-r--r--mdmv.1.pod31
4 files changed, 41 insertions, 1 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..286c187
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,8 @@
+MANPAGES=mdmv.1
+
+all: $(MANPAGES)
+
+%.1: %.1.pod
+ pod2man --section=1 --date="Debian Project" --center="User Commands" \
+ --name=$(subst .1,,$@) \
+ $^ $@
diff --git a/debian/control b/debian/control
index f7297e5..744b9d4 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: mail
Priority: optional
Maintainer: Sean Whitton <spwhitton@spwhitton.name>
Standards-Version: 4.1.5.0
-Build-Depends: debhelper (>= 10)
+Build-Depends: debhelper (>= 10), perl
Vcs-Git: https://git.spwhitton.name/mailscripts
Vcs-Browser: https://git.spwhitton.name/mailscripts
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 0000000..ef97a1f
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1 @@
+mdmv.1
diff --git a/mdmv.1.pod b/mdmv.1.pod
new file mode 100644
index 0000000..0da9cb2
--- /dev/null
+++ b/mdmv.1.pod
@@ -0,0 +1,31 @@
+=head1 NAME
+
+mdmv - safely move messages between maildirs
+
+=head1 SYNOPSYS
+
+ mdmv MSG [MSG..] DEST
+
+=head1 DESCRIPTION
+
+B<mdmv> moves one or more messages, from one or more maildirs, to a
+single destination maildir. It does this in a way that should not
+confuse maildir synchronisation tools.
+
+B<mdmv> tries to be sure not to overwrite any existing files, but it
+does not try as hard to "deliver" the mail to the destination maildir
+as a real MDA would, giving up rather earlier. Thus, B<mdmv> is
+intended to be used by scripts running on the same host upon which the
+maildirs are actually stored.
+
+=head1 OPTIONS
+
+None.
+
+=head1 SEE ALSO
+
+maildir(5)
+
+=head1 AUTHOR
+
+B<mdmv> was written by Sean Whitton <spwhitton@spwhitton.name>.