summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-11-17 10:21:06 -0700
committerSean Whitton <spwhitton@spwhitton.name>2018-11-17 10:21:06 -0700
commit14fbbc9f88793826ebd8f987122f560c9c20a5ba (patch)
tree8ab0e4544681eecc72571cf7565bc6497ae88c8a
parent5b6bdea015a9381a964555f8cfd8ba266f9d73d7 (diff)
parentcff0e39b9dbf35970ce154efb0621f5abbfd2387 (diff)
downloadmailscripts-14fbbc9f88793826ebd8f987122f560c9c20a5ba.tar.gz
Merge remote-tracking branch 'dgit/dgit/buster' into stretch-bpo
-rw-r--r--debian/changelog13
-rw-r--r--mailscripts.el3
-rwxr-xr-xnotmuch-slurp-debbug3
3 files changed, 18 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b2d36ea..66f9db3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+mailscripts (0.4-1) unstable; urgency=medium
+
+ * Do not import messages without a Message-Id header (Closes: #909835).
+ Thanks to David Bremner for the report.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Sat, 27 Oct 2018 10:56:10 -0700
+
+mailscripts (0.3-1) unstable; urgency=medium
+
+ * Add "Package-Requires: (notmuch)" (Closes: #909376).
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Sun, 23 Sep 2018 08:14:08 -0700
+
mailscripts (0.2-2~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports.
diff --git a/mailscripts.el b/mailscripts.el
index 9d80eac..249cb42 100644
--- a/mailscripts.el
+++ b/mailscripts.el
@@ -1,7 +1,8 @@
;;; mailscripts.el --- functions to access tools in the mailscripts package
;; Author: Sean Whitton <spwhitton@spwhitton.name>
-;; Version: 0.2
+;; Version: 0.4
+;; Package-Requires: (notmuch)
;; Copyright (C) 2018 Sean Whitton
diff --git a/notmuch-slurp-debbug b/notmuch-slurp-debbug
index 226a095..d289e31 100755
--- a/notmuch-slurp-debbug
+++ b/notmuch-slurp-debbug
@@ -89,6 +89,9 @@ system("mbox2maildir $mbox $dir") == 0
foreach my $message (glob "$dir/*/*") {
my $message_head = MIME::Head->from_file($message);
my $mid = $message_head->get('Message-ID');
+ # if this message does not have a message-id, do not import it;
+ # that is asking for trouble
+ next unless defined $mid;
$mid =~ s/(<|>)//g;
my $match = `notmuch search id:$mid`;
my $match_lines = $match =~ tr/\n//;