summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2022-04-04 14:57:01 -0700
committerSean Whitton <spwhitton@spwhitton.name>2022-04-04 14:57:01 -0700
commit718d9851b48dfd49a5bf109b6b8a073c172fb07f (patch)
treeaf6ceffaf68decd0fb412dc0e69ecee37f8c8b47
parent4de9d8cacde516fc5d38c6bddffbae39505e6f6a (diff)
downloadmailscripts-718d9851b48dfd49a5bf109b6b8a073c172fb07f.tar.gz
mailscripts.el: update mailscripts-project-library default value
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
-rw-r--r--debian/changelog4
-rw-r--r--mailscripts.el9
2 files changed, 6 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 63e79d0..48ed8cb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,10 @@ mailscripts (0.25-1) UNRELEASED; urgency=medium
* mdmv: ensure destination path ends with ':2,' when message has no flags.
Previously we were writing some messages with no flags into cur/
directories without this suffix, which is invalid (see maildir(5)).
+ * mailscripts.el: change mailscripts-project-library default to `project'.
+ Now that Emacs 28.1 is out, the latest stable release of Emacs
+ contains a more fully-featured version of project.el, so change the
+ default as we said we would.
-- Sean Whitton <spwhitton@spwhitton.name> Sun, 20 Mar 2022 14:44:31 -0700
diff --git a/mailscripts.el b/mailscripts.el
index feb8568..80beda2 100644
--- a/mailscripts.el
+++ b/mailscripts.el
@@ -48,19 +48,14 @@ Note that this does not prevent the creation of new branches."
(const :tag "Ask whether to detach" ask))
:group 'mailscripts)
-(defcustom mailscripts-project-library 'projectile
+(defcustom mailscripts-project-library 'project
"Which project management library to use to choose from known projects.
Some mailscripts functions allow selecting the repository to
which patches will be applied from the list of projects already
known to Emacs. There is more than one popular library for
maintaining a list of known projects, however, so this variable
-must be set to the one you use.
-
-Once there is a more fully-featured version of project.el
-included in the latest stable release of GNU Emacs, the default
-value of this variable may change, so if you wish to continue
-using Projectile, you should explicitly customize this."
+must be set to the one you use."
:type '(choice (const :tag "project.el" project)
(const :tag "Projectile" projectile))
:group 'mailscripts)