summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2019-05-17 10:12:52 -0700
committerSean Whitton <spwhitton@spwhitton.name>2019-05-17 10:12:52 -0700
commit49320906dbea62f1f2697ec0a6d85e7ca645b7cd (patch)
tree7cd8fcbd2cd1ba8755a9bdbc43c5881e751af4a0
parent251527b796c2ae1f951470cc72c61a615eb674ff (diff)
downloadmailscripts-49320906dbea62f1f2697ec0a6d85e7ca645b7cd.tar.gz
fix notmuch-extract-thread-patches docstring
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
-rw-r--r--debian/changelog7
-rw-r--r--mailscripts.el6
2 files changed, 11 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 875e015..f6e00fb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+mailscripts (0.9-1) UNRELEASED; urgency=medium
+
+ * Fix docstring for notmuch-extract-thread-patches not to say that the
+ target branch must not yet exist.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Fri, 17 May 2019 10:12:12 -0700
+
mailscripts (0.8-1) experimental; urgency=medium
* New scripts: maildir-import-patch(1), notmuch-import-patch(1)
diff --git a/mailscripts.el b/mailscripts.el
index 2ab871c..0198a3c 100644
--- a/mailscripts.el
+++ b/mailscripts.el
@@ -1,7 +1,7 @@
;;; mailscripts.el --- functions to access tools in the mailscripts package
;; Author: Sean Whitton <spwhitton@spwhitton.name>
-;; Version: 0.8
+;; Version: 0.9
;; Package-Requires: (notmuch)
;; Copyright (C) 2018 Sean Whitton
@@ -44,7 +44,9 @@ If NO-OPEN, don't open the thread."
;;;###autoload
(defun notmuch-extract-thread-patches (repo branch)
- "Extract patch series in current thread to new branch BRANCH in repo REPO.
+ "Extract patch series in current thread to branch BRANCH in repo REPO.
+
+The target branch may or may not already exist.
See notmuch-extract-patch(1) manpage for limitations: in
particular, this Emacs Lisp function supports passing only entire