summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rw-r--r--mailscripts.el2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 5624a7d..4e05959 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,8 @@ mailscripts (0.20-1) UNRELEASED; urgency=medium
creation of a new branch, but the old prompt suggests that inputting
an existing branch name would cause that branch to be checked out.
- Add mailscripts-detach-head-from-existing-branch defcustom.
+ - notmuch-extract-message-patches: set NO-STRICT-MIME argument of
+ `mm-dissect-buffer' to enable extracting patches from more messages.
* Add mailing list info to CONTRIBUTING.md.
-- Sean Whitton <spwhitton@spwhitton.name> Fri, 27 Mar 2020 11:50:27 -0700
diff --git a/mailscripts.el b/mailscripts.el
index 6fc8c69..193ca5c 100644
--- a/mailscripts.el
+++ b/mailscripts.el
@@ -123,7 +123,7 @@ git-format-patch(1)."
"Dgit repo: \nsnew branch name (or leave blank to apply to current HEAD): ")
(with-current-notmuch-show-message
(let ((default-directory (expand-file-name repo))
- (mm-handle (mm-dissect-buffer)))
+ (mm-handle (mm-dissect-buffer t)))
(mailscripts--check-out-branch branch)
(notmuch-foreach-mime-part
(lambda (p)