summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/control2
-rwxr-xr-xtests/email-print-mime-structure.sh6
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 2576d6c..0ef1ece 100644
--- a/debian/control
+++ b/debian/control
@@ -8,6 +8,8 @@ Build-Depends:
debhelper (>= 10),
dh-elpa,
diffutils <!nocheck>,
+ gpg <!nocheck>,
+ gpg-agent <!nocheck>,
perl,
python3 <!nocheck>,
python3-argcomplete,
diff --git a/tests/email-print-mime-structure.sh b/tests/email-print-mime-structure.sh
index 0c0bb50..d3d8b0c 100755
--- a/tests/email-print-mime-structure.sh
+++ b/tests/email-print-mime-structure.sh
@@ -14,6 +14,12 @@ for eml in tests/email-print-mime-structure/*.eml; do
if [ -e "$pgpkey" ]; then
printf "Testing %s (PGPy)\n" "${eml##*/}"
test_eml "$base" --pgpkey "$pgpkey"
+
+ testgpghome=$(mktemp -d)
+ printf "Testing %s (GnuPG)\n" "${eml##*/}"
+ gpg --homedir="$testgpghome" --batch --quiet --import < "$pgpkey"
+ GNUPGHOME="$testgpghome" test_eml "$base" --use-gpg-agent
+ rm -rf "$testgpghome"
else
printf "Testing %s\n" "${eml##*/}"
test_eml "$base"