summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--mailscripts.el4
2 files changed, 7 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index d6c2a7f..c530300 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,11 @@ mailscripts (0.20-1) UNRELEASED; urgency=medium
Thanks to Robbie Harwood for the patch.
* notmuch-slurp-debbug: Fix reading configuration file (Closes: #958391).
Thanks to intrigeri for the patch.
+ * mailscripts.el:
+ - Change prompt "branch name" -> "new branch name".
+ When the user inputs a branch name, it is used only to attempt the
+ creation of a new branch, but the old prompt suggests that inputting
+ an existing branch name would cause that branch to be checked out.
* Add mailing list info to CONTRIBUTING.md.
-- Sean Whitton <spwhitton@spwhitton.name> Fri, 27 Mar 2020 11:50:27 -0700
diff --git a/mailscripts.el b/mailscripts.el
index 0658c76..904a30a 100644
--- a/mailscripts.el
+++ b/mailscripts.el
@@ -67,7 +67,7 @@ See notmuch-extract-patch(1) manpage for limitations: in
particular, this Emacs Lisp function supports passing only entire
threads to the notmuch-extract-patch(1) command."
(interactive
- "Dgit repo: \nsbranch name (or leave blank to apply to current HEAD): \nP")
+ "Dgit repo: \nsnew branch name (or leave blank to apply to current HEAD): \nP")
(let ((thread-id
;; If `notmuch-show' was called with a notmuch query rather
;; than a thread ID, as `org-notmuch-follow-link' in
@@ -109,7 +109,7 @@ Patches are applied using git-am(1), so we only consider
attachments with filenames which look like they were generated by
git-format-patch(1)."
(interactive
- "Dgit repo: \nsbranch name (or leave blank to apply to current HEAD): ")
+ "Dgit repo: \nsnew branch name (or leave blank to apply to current HEAD): ")
(with-current-notmuch-show-message
(let ((default-directory (expand-file-name repo))
(mm-handle (mm-dissect-buffer)))