summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 352f6f0..0cd06b7 100644
--- a/Makefile
+++ b/Makefile
@@ -3,14 +3,21 @@ MANPAGES=mdmv.1 mbox2maildir.1 \
email-extract-openpgp-certs.1 \
email-print-mime-structure.1 \
notmuch-import-patch.1
+COMPLETIONS=completions/bash/email-print-mime-structure
-all: $(MANPAGES)
+all: $(MANPAGES) $(COMPLETIONS)
clean:
rm -f $(MANPAGES)
+ rm -rf completions
%.1: %.1.pod
pod2man --section=1 --date="Debian Project" --center="User Commands" \
--utf8 \
--name=$(subst .1,,$@) \
$^ $@
+
+completions/bash/%:
+ mkdir -p completions/bash
+ register-python-argcomplete3 $(notdir $@) > $@.tmp
+ mv $@.tmp $@