aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2021-02-27 16:55:45 -0700
committerSean Whitton <spwhitton@spwhitton.name>2021-02-27 16:55:45 -0700
commita9785ec40b9b6cc906d1cbe4dbaeec477f235148 (patch)
tree350b7abbe16f4a443c11ea8600720c5e3cb367de
parent9bfaeee3bfb0fa8e1f08a13dec2a7f20c6e65c5e (diff)
downloadconsfigurator-a9785ec40b9b6cc906d1cbe4dbaeec477f235148.tar.gz
debian/: add an autopkgtest to test compiling and loading
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
-rw-r--r--debian/changelog1
-rw-r--r--debian/tests/compile.lisp9
-rw-r--r--debian/tests/control3
-rw-r--r--doc/ideas.rst4
4 files changed, 13 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index c94a032..c07d365 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
consfigurator (0.0.1-2) UNRELEASED; urgency=medium
* Add dependencies on cl-babel, cl-cffi.
+ * Add an autopkgtest, marked as superficial, to test compiling and loading.
-- Sean Whitton <spwhitton@spwhitton.name> Sat, 27 Feb 2021 16:54:31 -0700
diff --git a/debian/tests/compile.lisp b/debian/tests/compile.lisp
new file mode 100644
index 0000000..b4377ba
--- /dev/null
+++ b/debian/tests/compile.lisp
@@ -0,0 +1,9 @@
+(require "asdf")
+
+;; this ensures that we've listed the files in consfigurator.asd in the
+;; correct order
+
+(let ((asdf:*compile-file-failure-behaviour* :error)
+ (asdf:*compile-file-warnings-behaviour* :error)
+ (asdf:*user-cache* (uiop:getenv "AUTOPKGTEST_TMP")))
+ (asdf:load-system "consfigurator"))
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..d3e3a1c
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,3 @@
+Test-Command: sbcl --script debian/tests/compile.lisp
+Depends: @, sbcl
+Restrictions: allow-stderr, superficial
diff --git a/doc/ideas.rst b/doc/ideas.rst
index a655422..8dfcbff 100644
--- a/doc/ideas.rst
+++ b/doc/ideas.rst
@@ -64,7 +64,3 @@ Project & packaging
- Define a semantics for version numbers (probably just like Propellor's),
start keeping a NEWS file and move from Debian experimental to unstable.
-
-- Add an autopkgtest, marked as superficial, which tries to load the system
- into sbcl and dies if there are any compiler warnings. Mainly to ensure
- that everything is loaded in the correct order.