summaryrefslogtreecommitdiff
path: root/.gitignore
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-03-17 11:33:48 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2017-03-17 11:42:34 -0700
commit2f8935099c680f5e25afdf290d351180ee42fa39 (patch)
tree900d6f682b94c4b5f5cfe435fd6910f6ad9b6b3e /.gitignore
parent65faa7bcb59421603ed2b6e961fe4b9ea8cb91b9 (diff)
downloademacs-2f8935099c680f5e25afdf290d351180ee42fa39.tar.gz
Fixups for GNU Make switchover
This fixes some minor problems introduced in the recent switch to GNU Make, discovered by further testing. Without some of these changes 'make -j' would sometimes have race conditions caused by missing dependencies. (Bug#26100) * .gitignore: Remove src/stamp-h.in, src/stamp-h1. * Makefile.in ($(MAKEFILE_NAME)): Depend on configure, not src/config.in, since the former's timestamp now represents the latter's. ($(srcdir)/configure): Use plain ./autogen.sh, for consistency with other autogen.sh invocations. ($(srcdir)/src/stamp-h.in): Remove rule, as this file is no longer created. * Makefile.in (top_distclean): * src/Makefile.in (bootstrap-clean): No need to remove stamp-h1, as that was an Automake byproduct and Automake is no longer in use. * lib/Makefile.in, src/Makefile.in: (AUTOCONF_INPUTS, $(top_srcdir)/configure): Remove. (../config.status, Makefile): Simplify by limiting dependencies to files we care about and files in the repository, and by using just one file to represent the timestamps on multiple targets updated by the same rule. * autogen.sh: Do not create or use src/stamp-h.in. Instead, have 'find' test the two output files directly.
Diffstat (limited to '.gitignore')
-rw-r--r--.gitignore2
1 files changed, 0 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index 6697a1ec841..ce1866d616b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -121,8 +121,6 @@ deps/
*.stamp
stamp_BLD
src/gl-stamp
-src/stamp-h.in
-src/stamp-h1
# Object files and debugging.
*.a