summaryrefslogtreecommitdiff
path: root/.gitignore
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2019-04-09 15:42:10 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2019-04-09 15:43:35 -0700
commitd82603747564063f908c9c877449c827a9808528 (patch)
treeb74dae7a9ab4d8b441141725f3455679d14f14aa /.gitignore
parente44ff2de819ead77b00c7fb4ede75ada685ff099 (diff)
downloademacs-d82603747564063f908c9c877449c827a9808528.tar.gz
Remove the need for temacs.in
Instead of building a file temacs.in used only to compute a fingerprint, compute the fingerprint directly from the .o and .a files that go into temacs.in. This speeds up the build by avoiding the need to link temacs twice, once with a dummy fingerprint. * lib-src/make-fingerprint.c (main): No need to generate a fingerprint file that includes config.h, now that fingerprint.c depends on all the .o files. * src/Makefile.in ($(libsrc)/make-fingerprint$(EXEEXT)): Use the same rule as $(libsrc)/make-docfile$(EXEEXT). * src/fingerprint-dummy.c: Remove. * src/Makefile.in (${charsets}, $(libsrc)/make-docfile$(EXEEXT)) ($(LIBEGNU_ARCHIVE), $(lwlibdir)/liblw.a, $(oldXMenudir)/libXMenu11.a) (../config.status, ${ETAGS}, ../lisp/TAGS, $(lwlibdir)/TAGS) ($(lispsource)/loaddefs.el): Prefer ‘$(MAKE) -C $(dir $@)’ to ‘${MAKE} -C SOMESTRING’ when either will do, as the former is more regular and lets us coalesce rules better. (EMACS_DEPS_PRE, EMACS_DEPS_POST, BUILD_EMACS_PRE) (BUILD_EMACS_POST, temacs.in$(EXEEXT)): Remove. (FINGERPRINTED): New macro. (fingerprint.c): Use it instead of temacs.in$(EXEEXT), to avoid the need to build temacs.in at all. (temacs$(EXEEXT)): No need to depend on other .o files now; fingerprint.o is enough, since it depends on the rest. Spell out what used to be in BUILD_EMACS_PRE and BUILD_EMACS_POST. (mostlyclean): No need to remove temacs.in.
Diffstat (limited to '.gitignore')
-rw-r--r--.gitignore1
1 files changed, 0 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index bd5a8e79471..98b8222180b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -185,7 +185,6 @@ src/bootstrap-emacs
src/emacs
src/emacs-[0-9]*
src/temacs
-src/temacs.in
src/fingerprint.c
src/*.pdmp