summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-05-27 09:45:49 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2020-05-27 09:51:12 -0700
commit9d11f127f15cc4dafcdb825dcfc6e495d729a069 (patch)
tree86ef1c845ace94bb75e689771906e54d274114c3
parent22446569cd319403e6e5e19369439ec71c46150d (diff)
downloademacs-9d11f127f15cc4dafcdb825dcfc6e495d729a069.tar.gz
--with-wide-int is a no-op on 64-bit hosts
* configure.ac: Clarify wording for --with-wide-int help. * src/pdumper.c (dump_vectorlike_generic): Do the eassert even if --with-wide-int was specified unnecessarily.
-rw-r--r--configure.ac6
-rw-r--r--src/pdumper.c2
2 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 719eb747ae1..b1b8c846e14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -414,7 +414,11 @@ this option's value should be 'yes', 'no', 'lucid', 'athena', 'motif', 'gtk',
with_x_toolkit=$val
])
-OPTION_DEFAULT_OFF([wide-int], [prefer wide Emacs integers (typically 62-bit); allows buffer and string size up to 2GB on 32-bit hosts, at the cost of 10% to 30% slowdown of Lisp interpreter and larger memory footprint])
+OPTION_DEFAULT_OFF([wide-int],
+ [prefer wide Emacs integers (typically 62-bit);
+ on 32-bit hosts, this allows buffer and string size up to 2GB,
+ at the cost of 10% to 30% slowdown of Lisp interpreter
+ and larger memory footprint])
if test "$with_wide_int" = yes; then
AC_DEFINE([WIDE_EMACS_INT], 1, [Use long long for EMACS_INT if available.])
fi
diff --git a/src/pdumper.c b/src/pdumper.c
index 63424c5734a..bac6900cd1a 100644
--- a/src/pdumper.c
+++ b/src/pdumper.c
@@ -2603,7 +2603,7 @@ dump_vectorlike_generic (struct dump_context *ctx,
Lisp_Object out;
const Lisp_Object *vslot = &v->contents[i];
/* In the wide case, we're always misaligned. */
-#ifndef WIDE_EMACS_INT
+#if INTPTR_MAX == EMACS_INT_MAX
eassert (ctx->offset % sizeof (out) == 0);
#endif
dump_object_start (ctx, &out, sizeof (out));