summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2022-01-12 09:35:43 -0800
committerGlenn Morris <rgm@gnu.org>2022-01-12 09:35:43 -0800
commit745580a36dc284d322a8d266ed39f80af3231d51 (patch)
tree04ce8828f5d721cfa7f49cc019fd95df67988df8
parentdb745f37aec2adc44ec4b2eae0720e0365ed0ca9 (diff)
downloademacs-745580a36dc284d322a8d266ed39f80af3231d51.tar.gz
Avoid user environment interfering with bootstrap
* Makefile.in, admin/unidata/Makefile.in: * doc/misc/Makefile.in, lib-src/Makefile.in: Don't export user environment variables that can affect running emacs. (Bug#53038)
-rw-r--r--Makefile.in3
-rw-r--r--admin/unidata/Makefile.in3
-rw-r--r--doc/misc/Makefile.in4
-rw-r--r--lib-src/Makefile.in3
4 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index b72127dde67..8ac6f527469 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -319,6 +319,9 @@ GLIB_COMPILE_SCHEMAS = glib-compile-schemas
# Program name transformation.
TRANSFORM = @program_transform_name@
+# Prevent any settings in the user environment causing problems.
+unexport EMACSDATA EMACSDOC EMACSLOADPATH EMACSPATH
+
# What emacs should be called when installed.
EMACS_NAME = `echo emacs | sed '$(TRANSFORM)'`
EMACS = ${EMACS_NAME}${EXEEXT}
diff --git a/admin/unidata/Makefile.in b/admin/unidata/Makefile.in
index 45bba85213b..e75010dc2b8 100644
--- a/admin/unidata/Makefile.in
+++ b/admin/unidata/Makefile.in
@@ -29,6 +29,9 @@ srcdir = @srcdir@
top_srcdir = @top_srcdir@
top_builddir = @top_builddir@
+# Prevent any settings in the user environment causing problems.
+unexport EMACSDATA EMACSDOC EMACSLOADPATH EMACSPATH
+
EMACS = ${top_builddir}/src/emacs
unidir = ${top_srcdir}/lisp/international
emacs = "${EMACS}" -batch --no-site-file --no-site-lisp
diff --git a/doc/misc/Makefile.in b/doc/misc/Makefile.in
index 6c1e9cbc910..d348dbc194b 100644
--- a/doc/misc/Makefile.in
+++ b/doc/misc/Makefile.in
@@ -234,6 +234,10 @@ ${buildinfodir}/tramp.info tramp.html: ${srcdir}/trampver.texi
abs_top_builddir = @abs_top_builddir@
+
+# Prevent any settings in the user environment causing problems.
+unexport EMACSDATA EMACSDOC EMACSLOADPATH EMACSPATH
+
EMACS = ${abs_top_builddir}/src/emacs
emacs = "${EMACS}" -batch --no-site-file --no-site-lisp --eval '(setq load-prefer-newer t)'
diff --git a/lib-src/Makefile.in b/lib-src/Makefile.in
index c25ba5c974d..0453b935068 100644
--- a/lib-src/Makefile.in
+++ b/lib-src/Makefile.in
@@ -20,6 +20,9 @@
SHELL = @SHELL@
+# Prevent any settings in the user environment causing problems.
+unexport EMACSDATA EMACSDOC EMACSLOADPATH EMACSPATH
+
# Following ../lisp/Makefile.in.
EMACS = ../src/emacs${EXEEXT}
EMACSOPT = -batch --no-site-file --no-site-lisp