summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo Lu <luangruo@yahoo.com>2022-05-04 16:48:24 +0800
committerPo Lu <luangruo@yahoo.com>2022-05-04 16:51:48 +0800
commit0105a4ddb8a58146f3fc71c265e57291c873af0b (patch)
treeba28d987eb1c1a870a4d070317b18eb60f42ead1
parent69521ffcb0f2a28f84e24137bfc789ffd0ec3f2f (diff)
downloademacs-0105a4ddb8a58146f3fc71c265e57291c873af0b.tar.gz
Turn on XInput 2 support by default
The support doesn't interfere with compatibility, since Emacs built with XInput 2 support transparently falls back to Core Input when a suitable version of the input extension is not available. It also matured much sooner than expected, so enabling this by default will lead to new features being available to more users. * INSTALL: * configure.ac: * etc/NEWS: Enable XInput 2 support by default.
-rw-r--r--INSTALL6
-rw-r--r--configure.ac2
-rw-r--r--etc/NEWS9
3 files changed, 9 insertions, 8 deletions
diff --git a/INSTALL b/INSTALL
index f2687225daf..95d2dbda80c 100644
--- a/INSTALL
+++ b/INSTALL
@@ -358,9 +358,9 @@ Use --without-toolkit-scroll-bars to disable Motif or Xaw3d scroll bars.
Use --without-xim to inhibit the default use of X Input Methods.
In this case, the X resource useXIM can be used to turn on use of XIM.
-Use --with-xinput2 to enable the use of version 2 of the X Input
-Extension. This enables support for touchscreens, pinch gestures, and
-scroll wheels that report scroll deltas at pixel-level precision.
+Use --without-xinput2 to disable the use of version 2 of the X Input
+Extension. This disables support for touchscreens, pinch gestures,
+and scroll wheels that report scroll deltas at pixel-level precision.
Use --disable-largefile to omit support for files larger than 2GB, and
--disable-year2038 to omit support for timestamps past the year 2038,
diff --git a/configure.ac b/configure.ac
index b7189593a63..484ce980a52 100644
--- a/configure.ac
+++ b/configure.ac
@@ -490,7 +490,7 @@ OPTION_DEFAULT_ON([modules],[don't compile with dynamic modules support])
OPTION_DEFAULT_ON([threads],[don't compile with elisp threading support])
OPTION_DEFAULT_OFF([native-compilation],[compile with Emacs Lisp native compiler support])
OPTION_DEFAULT_OFF([cygwin32-native-compilation],[use native compilation on 32-bit Cygwin])
-OPTION_DEFAULT_OFF([xinput2],[use version 2 of the X Input Extension for input])
+OPTION_DEFAULT_ON([xinput2],[don't use version 2 of the X Input Extension for input])
AC_ARG_WITH([file-notification],[AS_HELP_STRING([--with-file-notification=LIB],
[use a file notification library (LIB one of: yes, inotify, kqueue, gfile, w32, no)])],
diff --git a/etc/NEWS b/etc/NEWS
index 73e61aab327..1fd7e0bd24c 100644
--- a/etc/NEWS
+++ b/etc/NEWS
@@ -59,10 +59,11 @@ If a constant file name is required, the file can be renamed to
"emacs.pdmp", and Emacs will find it during startup anyway.
---
-** Emacs now supports use of XInput 2 for input events.
-If your X server has support and you have the XInput 2 development headers
-installed, you can configure Emacs with the option '--with-xinput2' to enable
-this support.
+** Emacs now uses of XInput 2 for input events.
+If your X server has support and you have the XInput 2 development
+headers installed, Emacs will use the X Input Extension for handling
+input. If this causes problems, you can configure Emacs with the
+option '--without-xinput2' to disable this support.
The named feature 'xinput2' can be used to test for the presence of
XInput 2 support from Lisp programs.