summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@suse.de>2022-08-25 09:51:40 +0200
committerEli Zaretskii <eliz@gnu.org>2022-08-25 12:20:35 +0300
commit82bcd443782738fd163b282497de5501d03f175a (patch)
tree48ea32d86f688486e2ec9f84f9ce64e32fe365a2
parent1dd0a5c5db51ec93df0eeab003b458f4354ffde7 (diff)
downloademacs-82bcd443782738fd163b282497de5501d03f175a.tar.gz
* configure.ac: Move AC_LANG_PUSH/POP out of AC_CACHE_CHECK. (Bug#57380)
(cherry picked from commit ce82300221f270241fdda1f5dfb567bdb1208543)
-rw-r--r--configure.ac24
1 files changed, 11 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index bc7485b81c8..7c98522448b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2047,17 +2047,16 @@ AC_SUBST(NS_OBJ)
AC_SUBST(NS_OBJC_OBJ)
if test "${HAVE_NS}" = yes; then
+ AC_LANG_PUSH([Objective C])
AC_CACHE_CHECK(
[if the Objective C compiler supports instancetype],
[emacs_cv_objc_instancetype],
- [AC_LANG_PUSH([Objective C])
- AC_COMPILE_IFELSE(
+ [AC_COMPILE_IFELSE(
[AC_LANG_SOURCE([[@interface Test
+ (instancetype)test;
@end]])],
- emacs_cv_objc_instancetype=yes,
- emacs_cv_objc_instancetype=no)
- AC_LANG_POP([Objective C])])
+ [emacs_cv_objc_instancetype=yes],
+ [emacs_cv_objc_instancetype=no])])
if test x$emacs_cv_objc_instancetype = xyes ; then
AC_DEFINE(NATIVE_OBJC_INSTANCETYPE, 1,
@@ -2067,16 +2066,15 @@ if test "${HAVE_NS}" = yes; then
AC_CACHE_CHECK(
[if the Objective C compiler defaults to C99],
[emacs_cv_objc_c99],
- [AC_LANG_PUSH([Objective C])
- AC_COMPILE_IFELSE(
+ [AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM([], [[for (int i = 0;;);]])],
- emacs_cv_objc_c99=yes,
- emacs_cv_objc_c99=no)
- AC_LANG_POP([Objective C])])
+ [emacs_cv_objc_c99=yes],
+ [emacs_cv_objc_c99=no])])
- if test x$emacs_cv_objc_c99 = xno ; then
- GNU_OBJC_CFLAGS="$GNU_OBJC_CFLAGS -std=c99"
- fi
+ if test x$emacs_cv_objc_c99 = xno ; then
+ GNU_OBJC_CFLAGS="$GNU_OBJC_CFLAGS -std=c99"
+ fi
+ AC_LANG_POP([Objective C])
fi
HAVE_W32=no