summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Albinus <michael.albinus@gmx.de>2022-07-13 13:21:45 +0200
committerMichael Albinus <michael.albinus@gmx.de>2022-07-13 13:21:45 +0200
commit2209650089851b7ec7b0a87bd73a878f2da6975f (patch)
tree9bd2e59b4d3c3448dcc2bd08e60141b9e38dadee
parent5e47ec95118c06dd66cd488ad25775d801d75c0c (diff)
downloademacs-2209650089851b7ec7b0a87bd73a878f2da6975f.tar.gz
Adapt Tramp version (don't merge)
* doc/misc/trampver.texi: * lisp/net/trampver.el: Change version to "2.5.3.28.2". (customize-package-emacs-version-alist): Add Tramp version integrated in Emacs 28.2.
-rw-r--r--doc/misc/trampver.texi2
-rw-r--r--lisp/net/trampver.el8
2 files changed, 5 insertions, 5 deletions
diff --git a/doc/misc/trampver.texi b/doc/misc/trampver.texi
index 580d9ba69e4..8352fed1b70 100644
--- a/doc/misc/trampver.texi
+++ b/doc/misc/trampver.texi
@@ -8,7 +8,7 @@
@c In the Tramp GIT, the version numbers are auto-frobbed from
@c tramp.el, and the bug report address is auto-frobbed from
@c configure.ac.
-@set trampver 2.5.3
+@set trampver 2.5.3.28.2
@set trampurl https://www.gnu.org/software/tramp/
@set tramp-bug-report-address tramp-devel@@gnu.org
@set emacsver 25.1
diff --git a/lisp/net/trampver.el b/lisp/net/trampver.el
index c1d58a45f4f..e14c26d8999 100644
--- a/lisp/net/trampver.el
+++ b/lisp/net/trampver.el
@@ -7,7 +7,7 @@
;; Maintainer: Michael Albinus <michael.albinus@gmx.de>
;; Keywords: comm, processes
;; Package: tramp
-;; Version: 2.5.3
+;; Version: 2.5.3.28.2
;; Package-Requires: ((emacs "25.1"))
;; Package-Type: multi
;; URL: https://www.gnu.org/software/tramp/
@@ -40,7 +40,7 @@
;; ./configure" to change them.
;;;###tramp-autoload
-(defconst tramp-version "2.5.3"
+(defconst tramp-version "2.5.3.28.2"
"This version of Tramp.")
;;;###tramp-autoload
@@ -78,7 +78,7 @@
;; Check for Emacs version.
(let ((x (if (not (string-lessp emacs-version "25.1"))
"ok"
- (format "Tramp 2.5.3 is not fit for %s"
+ (format "Tramp 2.5.3.28.2 is not fit for %s"
(replace-regexp-in-string "\n" "" (emacs-version))))))
(unless (string-equal "ok" x) (error "%s" x)))
@@ -104,7 +104,7 @@
("2.3.3" . "26.1") ("2.3.3.26.1" . "26.1") ("2.3.5.26.2" . "26.2")
("2.3.5.26.3" . "26.3")
("2.4.3.27.1" . "27.1") ("2.4.5.27.2" . "27.2")
- ("2.5.2.28.1" . "28.1")))
+ ("2.5.2.28.1" . "28.1") ("2.5.3.28.2" . "28.2")))
(add-hook 'tramp-unload-hook
(lambda ()