summaryrefslogtreecommitdiff
path: root/ChangeLog.1
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2015-04-09 10:16:26 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2015-04-09 10:22:42 -0700
commitcbef1e918d5b0a7f2f68eb6d742982987f102cf4 (patch)
tree8fa512463768563b7cd98592479678895ccf7425 /ChangeLog.1
parent7bb614e399300a80a68cd5196c1fd1f96d44e0af (diff)
downloademacs-cbef1e918d5b0a7f2f68eb6d742982987f102cf4.tar.gz
; make change-history-commit
Diffstat (limited to 'ChangeLog.1')
-rw-r--r--ChangeLog.1244
1 files changed, 244 insertions, 0 deletions
diff --git a/ChangeLog.1 b/ChangeLog.1
index 6e2b4fc19d8..b8e2c614585 100644
--- a/ChangeLog.1
+++ b/ChangeLog.1
@@ -1,3 +1,247 @@
+2015-04-09 Paul Eggert <eggert@cs.ucla.edu>
+
+ Adapt 'make change-history' to coding cookie
+ * Makefile.in (change-history): Adjust to change of format of
+ ChangeLog file, which now has a coding cookie before an indented
+ copyright notice.
+
+ gitlog-to-changelog coding cookie and mv -i
+ * build-aux/gitlog-to-emacslog: Use ChangeLog.1, not Makefile.in,
+ for copyright notice prototype, so that we get a proper "coding:"
+ cookie. Use 'mv -i' to avoid unconditionally overwriting an
+ existing ChangeLog. Problems reported by Eli Zaretskii in:
+ http://lists.gnu.org/archive/html/emacs-devel/2015-04/msg00504.html
+
+ Merge from gnulib
+ * build-aux/gitlog-to-changelog: Update from gnulib, incorporating:
+ 2015-04-09 gitlog-to-changelog: port to MS-Windows
+
+2015-04-09 Boruch Baum <boruch_baum@gmx.com>
+
+ * lisp/bookmark.el (bookmark-bmenu-goto-bookmark): Don't inf-loop.
+ Fixes: debbugs:20212
+
+2015-04-09 Stefan Monnier <monnier@iro.umontreal.ca>
+
+ Stop messing with the EMACS env var
+ Fixes: debbugs:20202
+ * lisp/net/tramp-sh.el (tramp-remote-process-environment):
+ * lisp/comint.el (comint-exec-1):
+ * lisp/term.el (term-exec-1): Don't set EMACS envvar.
+ * lisp/progmodes/compile.el (compilation-start): Same and bring
+ INSIDE_EMACS's format in line with other users.
+
+ css-mode.el (css-smie-rules): Fix indentation after complex selectors
+ Fixes: debbugs:20282
+ * lisp/textmodes/css-mode.el (css-smie-rules): Don't get confused by
+ inner structure of selectors.
+
+2015-04-08 Fabián Ezequiel Gallina <fgallina@gnu.org>
+
+ python.el: Indent docstring lines to base-indent
+ Fixes: debbugs:19595
+ Thanks to immerrr <immerrr@gmail.com> for reporting and providing
+ an initial patch.
+ * lisp/progmodes/python.el
+ (python-indent-context): Add :inside-docstring context.
+ (python-indent--calculate-indentation): Handle :inside-docstring.
+ (python-indent-region): Re-indent docstrings.
+ * test/automated/python-tests.el (python-indent-region-5)
+ (python-indent-inside-string-2): Fix tests.
+
+ python.el: Increase native completion robustness
+ Fixes: debbugs:19755
+ Thanks to Carlos Pita <carlosjosepita@gmail.com> for reporting
+ this and providing useful ideas.
+ * lisp/progmodes/python.el
+ (python-shell-completion-native-output-timeout): Increase value.
+ (python-shell-completion-native-try-output-timeout): New var.
+ (python-shell-completion-native-try): Use it.
+ (python-shell-completion-native-setup): New readline setup avoids
+ polluting current context, ensures output when no-completions are
+ available and includes output end marker.
+ (python-shell-completion-native-get-completions): Trigger with one
+ tab only. Call accept-process-output until output end is found or
+ python-shell-completion-native-output-timeout is exceeded.
+
+2015-04-08 Samer Masterson <samer@samertm.com>
+
+ * lisp/eshell: Make backslash a no-op in front of normal chars
+ Fixes: debbugs:8531
+ * lisp/eshell/esh-arg.el (eshell-parse-argument-hook): Update comment.
+ (eshell-parse-backslash): Return escaped character after backslash
+ if it is special. Otherwise, if the backslash is not in a quoted
+ string, ignore the backslash and return the character after; if
+ the backslash is in a quoted string, return the backslash and the
+ character after.
+ * test/automated/eshell.el (eshell-test/escape-nonspecial)
+ (eshell-test/escape-nonspecial-unicode)
+ (eshell-test/escape-nonspecial-quoted)
+ (eshell-test/escape-special-quoted): Add tests for new
+ `eshell-parse-backslash' behavior.
+
+2015-04-08 Gustav Hållberg <gustav@gmail.com>
+
+ (diff-hunk-file-names): Don't require a TAB after the file name
+ Fixes: debbugs:20276
+
+ (diff-hunk-file-names): Don't require a TAB after the file name
+ * lisp/vc/diff-mode.el (diff-hunk-file-names): Don't require a TAB
+ after the file name (bug#20276).
+
+2015-04-08 Paul Eggert <eggert@cs.ucla.edu>
+
+ Minor quoting etc. fixes to Emacs manual
+ * doc/emacs/Makefile.in, doc/emacs/ack.texi, doc/emacs/building.texi:
+ * doc/emacs/calendar.texi, doc/emacs/cmdargs.texi:
+ * doc/emacs/custom.texi, doc/emacs/dired.texi, doc/emacs/emacs.texi:
+ * doc/emacs/files.texi, doc/emacs/glossary.texi, doc/emacs/gnu.texi:
+ * doc/emacs/indent.texi, doc/emacs/macos.texi:
+ * doc/emacs/maintaining.texi, doc/emacs/makefile.w32-in:
+ * doc/emacs/programs.texi, doc/emacs/rmail.texi:
+ * doc/emacs/search.texi, doc/emacs/trouble.texi:
+ * doc/emacs/vc1-xtra.texi:
+ Use American-style double quoting in ordinary text,
+ and quote 'like this' when single-quoting in ASCII text.
+ Also, fix some minor spacing issues.
+
+ Minor quoting etc. fixes to elisp intro
+ * doc/lispintro/emacs-lisp-intro.texi: Consistently use
+ American-style double quoting in ordinary text. In ASCII text,
+ consistently quote 'like this' instead of `like this', unless
+ Emacs requires the latter.
+
+2015-04-08 Dmitry Gutov <dgutov@yandex.ru>
+
+ CONTRIBUTE: Mention log-edit-insert-changelog
+
+ CONTRIBUTE: Emphasize creating the top-level ChangeLog file manually
+
+2015-04-08 Paul Eggert <eggert@cs.ucla.edu>
+
+ * doc/misc/calc.texi (Summary): Avoid '@:' when usurped.
+
+2015-04-08 Stefan Monnier <monnier@iro.umontreal.ca>
+
+ (eieio-copy-parents-into-subclass): Fix inheritance of initargs
+ Fixes: debbugs:20270
+ * lisp/emacs-lisp/eieio-core.el (eieio-copy-parents-into-subclass):
+ Fix inheritance of initargs.
+
+2015-04-08 Artur Malabarba <bruce.connor.am@gmail.com>
+
+ * lisp/emacs-lisp/package.el (package-menu-mode): Mode-line notification
+ while dowloading information.
+
+ * lisp/emacs-lisp/package.el: More conservative `ensure-init-file'
+ (package--ensure-init-file): Check file contents before visiting.
+ (package-initialize): Call it.
+ (package-install-from-buffer, package-install): Don't call it.
+
+2015-04-08 Eli Zaretskii <eliz@gnu.org>
+
+ * src/eval.c (init_eval_once): Bump max_lisp_eval_depth to 800
+ Fixes: bug#17517
+
+2015-04-08 Michael Albinus <michael.albinus@gmx.de>
+
+ Merge branch 'master' of git.sv.gnu.org:/srv/git/emacs
+
+ Fix nasty scoping bug in tramp-cache.el
+ * lisp/net/tramp-cache.el (tramp-flush-file-property): Fix nasty scoping bug.
+
+2015-04-08 Tassilo Horn <tsdh@gnu.org>
+
+ Add notice to visual commands section
+ * doc/misc/eshell.texi (Input/Output): Add notice that some tools
+ such as git call less with its -F option which omits pagination if
+ the contents is less than one page long. This interferes with
+ eshell's visual (sub-)commands.
+
+2015-04-07 Dmitry Gutov <dgutov@yandex.ru>
+
+ ffap: Support environment variable expansion in file names
+ Fixes: debbugs:19839
+ * lisp/ffap.el (ffap-string-at-point-mode-alist): Support
+ environment variable expansion in file names.
+
+2015-04-07 Paul Eggert <eggert@cs.ucla.edu>
+
+ Prefer double-quote to accent-grave in man pages
+
+2015-04-07 Stefan Monnier <monnier@iro.umontreal.ca>
+
+ Fixes: debbugs:20257
+ * lisp/files.el (set-visited-file-name): Clear auto-save if nil.
+
+2015-04-07 Ivan Shmakov <ivan@siamics.net>
+
+ Update etc/PROBLEMS.
+ * etc/PROBLEMS: Mention visible-cursor; a few more mentions of
+ ~/.Xresources and xrdb(1); refer to 'GNU Coreutils' and
+ 'X Window System' or 'X' (were: 'GNU Fileutils' and 'X Windows',
+ respectively); other minor updates and tweaks. (Bug#20011)
+
+2015-04-07 Paul Eggert <eggert@cs.ucla.edu>
+
+ Add doc strings for some Isearch state vars
+ * lisp/misearch.el (multi-isearch-buffer-list)
+ (multi-isearch-file-list): Add doc strings.
+ Fixes: bug#20232
+
+2015-04-07 Alan Mackenzie <acm@muc.de>
+
+ Always mark "<" and ">" in #include directives with text properties.
+ * lisp/progmodes/c-fonts.el (c-cpp-matchers): Replace a font-lock "anchored
+ matcher" with an invocation of c-make-font-lock-search-function to allow
+ fontification when there's no trailing space on an "#include <..>" line.
+
+2015-04-07 Paul Eggert <eggert@cs.ucla.edu>
+
+ Generate a ChangeLog file from commit logs
+ * .gitignore: Add 'ChangeLog'.
+ * build-aux/gitlog-to-changelog: New file, from Gnulib.
+ * build-aux/gitlog-to-emacslog: New file.
+ * CONTRIBUTE: Document the revised workflow.
+ * Makefile.in (clean): Remove *.tmp and etc/*.tmp*
+ instead of just special cases.
+ (CHANGELOG_HISTORY_INDEX_MAX, CHANGELOG_N, gen_origin): New vars.
+ (ChangeLog, unchanged-history-files, change-history)
+ (change-history-commit): New rules.
+ * admin/admin.el (make-manuals-dist--1):
+ Don't worry about doc/ChangeLog.
+ * admin/authors.el: Add a FIXME.
+ * admin/make-tarball.txt:
+ * lisp/calendar/icalendar.el:
+ * lisp/gnus/deuglify.el:
+ * lisp/obsolete/gulp.el:
+ * lwlib/README:
+ Adjust to renamed ChangeLog history files.
+ * admin/merge-gnulib (GNULIB_MODULES): Add gitlog-to-changelog.
+ * admin/notes/repo: Call it 'master' a la Git, not 'trunk' a la Bzr.
+ Remove obsolete discussion of merging ChangeLog files.
+ New section "Maintaining ChangeLog history".
+ * build-aux/git-hooks/pre-commit:
+ Reject attempts to commit files named 'ChangeLog'.
+ * lib/gnulib.mk, m4/gnulib-comp.m4: Regenerate.
+ * make-dist: Make and distribute top-level ChangeLog if there's a
+ .git directory. Distribute the new ChangeLog history files
+ instead of scattered ChangeLog files. Distribute the new files
+ gitlog-to-changelog and gitlog-to-emacslog.
+ Fixes: bug#19113
+
+ Rename ChangeLogs for gitlog-to-changelog
+ This patch was implemented via the following shell commands:
+ find * -name ChangeLog |
+ sed 's,.*,git mv & &.1,
+ s, lisp/ChangeLog\.1$, lisp/ChangeLog.17,
+ s, lisp/erc/ChangeLog\.1$, lisp/erc/ChangeLog.09,
+ s, lisp/gnus/ChangeLog\.1$, lisp/gnus/ChangeLog.3,
+ s, lisp/mh-e/ChangeLog\.1$, lisp/mh-e/ChangeLog.2,
+ s, src/ChangeLog\.1$, src/ChangeLog.13,' |
+ sh
+ git commit -am"[this commit message]"
+
2015-04-07 Paul Eggert <eggert@cs.ucla.edu>
Merge from gnulib