summaryrefslogtreecommitdiff
path: root/ChangeLog.3
diff options
context:
space:
mode:
authorNicolas Petton <nicolas@petton.fr>2020-08-04 21:32:27 +0200
committerNicolas Petton <nicolas@petton.fr>2020-08-04 21:32:27 +0200
commita68b3f761aa299e9449785476ba9a9777d38ae22 (patch)
tree71821164af1f1db00faf1cafbeff15b8e9008ae7 /ChangeLog.3
parent7cc85e7b5120a5a5effad12087b5af02f69b94ed (diff)
downloademacs-a68b3f761aa299e9449785476ba9a9777d38ae22.tar.gz
; Update ChangeLog.3
Diffstat (limited to 'ChangeLog.3')
-rw-r--r--ChangeLog.398
1 files changed, 97 insertions, 1 deletions
diff --git a/ChangeLog.3 b/ChangeLog.3
index c8dd40b5eb6..6418f9c8a2c 100644
--- a/ChangeLog.3
+++ b/ChangeLog.3
@@ -1,3 +1,99 @@
+2020-08-03 Phil Sainty <psainty@orcon.net.nz>
+
+ lisp/so-long.el: Improve support for major mode hooks
+
+ * lisp/so-long.el (so-long-remember-all, so-long-disable-minor-modes)
+ (so-long-override-variables): Store and use the `so-long-minor-modes'
+ and `so-long-variable-overrides' values seen by the original major
+ mode, so that buffer-local changes made in the major mode hook will be
+ respected.
+
+ Add documentation of this and other major mode hook usage.
+
+2020-08-02 Grégory Mounié <Gregory.Mounie@imag.fr> (tiny change)
+
+ Avoid segfaults if XIM is set but not xim_styles
+
+ Emacs segfaults at the X11 initialization if XIM is set
+ and xim_styles is NULL. This patch avoids the crash.
+ * src/xfns.c: Check also if FRAME_X_XIM_STYLES(f) is NULL.
+ (Bug#42676) (Bug#42673) (Bug#42677)
+
+2020-07-31 Philipp Stephani <phst@google.com>
+
+ Backport: Make checking for liveness of global values more precise.
+
+ We can't just use a hash lookup because a global and a local reference
+ might refer to the same Lisp object.
+
+ * src/emacs-module.c (module_free_global_ref): More precise check for
+ global liveness.
+
+ (cherry picked from commit 9f01ce6327af886f26399924a9aadf16cdd4fd9f)
+
+2020-07-31 Philipp Stephani <phst@google.com>
+
+ Backport: Fix subtle bug when checking liveness of module values.
+
+ We can't simply look up the Lisp object in the global reference table
+ because an invalid local and a valid global reference might refer to
+ the same object. Instead, we have to test the address of the global
+ reference against the stored references.
+
+ * src/emacs-module.c (module_global_reference_p): New helper function.
+ (value_to_lisp): Use it.
+
+ (cherry picked from commit 6355a3ec62f43c9b99d483982ff851d32dd78891)
+
+2020-07-31 Philipp Stephani <phst@google.com>
+
+ Backport: Fix memory leak for global module objects (Bug#42482).
+
+ Instead of storing the global values in a global 'emacs_value_storage'
+ object, store them as hash values alongside the reference counts.
+ That way the garbage collector takes care of cleaning them up.
+
+ * src/emacs-module.c (global_storage): Remove.
+ (struct module_global_reference): New pseudovector type.
+ (XMODULE_GLOBAL_REFERENCE): New helper function.
+ (module_make_global_ref, module_free_global_ref): Use
+ 'module_global_reference' struct for global reference values.
+ (value_to_lisp, module_handle_nonlocal_exit): Adapt to deletion of
+ 'global_storage'.
+
+ (cherry picked from commit 5c5eb9790898e4ab10bcbbdb6871947ed3018569)
+
+2020-07-30 Nicolas Petton <nicolas@petton.fr>
+
+ * admin/authors.el (authors-aliases): Remove a faulty regexp.
+
+2020-07-29 Stefan Kangas <stefankangas@gmail.com>
+
+ * doc/lispref/symbols.texi (Definitions): Fix typo.
+
+2020-07-28 Nicolas Petton <nicolas@petton.fr>
+
+ * etc/HISTORY: Add Emacs 27.1 release date.
+
+2020-07-28 Nicolas Petton <nicolas@petton.fr>
+
+ Bump Emacs version to 27.1
+
+ * README:
+ * configure.ac:
+ * msdos/sed2v2.inp:
+ * nt/README.W32: Bump Emacs version.
+
+2020-07-28 Nicolas Petton <nicolas@petton.fr>
+
+ * etc/AUTHORS: Update.
+
+2020-07-28 Nicolas Petton <nicolas@petton.fr>
+
+ Update authors.el
+
+ * admin/authors.el (authors-aliases): Add author aliases.
+
2020-07-28 Nicolas Petton <nicolas@petton.fr>
* etc/NEWS: Remove temporary markup.
@@ -142382,7 +142478,7 @@
This file records repository revisions from
commit 9d56a21e6a696ad19ac65c4b405aeca44785884a (exclusive) to
-commit 56f958807c0b8ea8f45e3c088157ca144a1b1fac (inclusive).
+commit 1ca4da054be7eb340c511d817f3ec89c8b819db7 (inclusive).
See ChangeLog.2 for earlier changes.
;; Local Variables: