summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2021-03-06 10:38:07 -0800
committerGlenn Morris <rgm@gnu.org>2021-03-06 10:38:07 -0800
commitc3cf99f53714ce1227ab508c9e359910a963659e (patch)
treed47a508a3cadf246e722c0780593edbc74d17755 /Makefile.in
parent8fc6810eb640ffe7af1885166814689f5b28a65e (diff)
downloademacs-c3cf99f53714ce1227ab508c9e359910a963659e.tar.gz
Remove the --without-makeinfo configure option (bug#46837)
* configure.ac (--without-makeinfo): Remove option. (HAVE_MAKEINFO): Remove output variable. * Makefile.in (HAVE_MAKEINFO): Remove. (info_misc): Remove HAVE_MAKEINFO check. (info-real): Remove target. (info): Simplify. ; * etc/NEWS: Mention this.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in31
1 files changed, 3 insertions, 28 deletions
diff --git a/Makefile.in b/Makefile.in
index 856c29a453e..85d063d8f6b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -166,9 +166,6 @@ infodir=@infodir@
# Info files not in the doc/misc directory (we get those via make echo-info).
INFO_NONMISC=emacs.info eintr.info elisp.info
-# If no makeinfo was found and configured --without-makeinfo, "no"; else "yes".
-HAVE_MAKEINFO=@HAVE_MAKEINFO@
-
# Directory for local state files for all programs.
localstatedir=@localstatedir@
@@ -650,9 +647,6 @@ install-etcdoc: src install-arch-indep
## If info/dir is missing, but we have install-info, we should let
## that handle it. If info/dir is present and we do not have install-info,
## we should check for missing entries and add them by hand.
-##
-## FIXME:
-## If HAVE_MAKEINFO = no and there are no info files, do not install info/dir.
install-info: info
umask 022; ${MKDIR_P} "$(DESTDIR)${infodir}"
-unset CDPATH; \
@@ -667,7 +661,6 @@ install-info: info
info_misc=`$(MAKE) --no-print-directory -s -C doc/misc echo-info`; \
cd ${srcdir}/info ; \
for elt in ${INFO_NONMISC} $${info_misc}; do \
- test "$(HAVE_MAKEINFO)" = "no" && test ! -f $$elt && continue; \
for f in `ls $$elt $$elt-[1-9] $$elt-[1-9][0-9] 2>/dev/null`; do \
(cd "$${thisdir}"; \
${INSTALL_DATA} ${srcdir}/info/$$f "$(DESTDIR)${infodir}/$$f"); \
@@ -987,13 +980,13 @@ $(DOCS):
$(MAKE) -C doc/$(subst -, ,$@)
.PHONY: $(DOCS) docs pdf ps
-.PHONY: info dvi dist html info-real info-dir check-info
+.PHONY: info dvi dist html info-dir check-info
## TODO add etc/refcards.
docs: $(DOCS)
dvi: $(DVIS)
html: $(HTMLS)
-info-real: $(INFOS)
+info: $(INFOS) info-dir
pdf: $(PDFS)
ps: $(PSS)
@@ -1027,7 +1020,7 @@ info_dir_deps = \
## installation location by the install-info rule, but we also
## need one in the source directory for people running uninstalled.
## FIXME it would be faster to use the install-info program if we have it,
-## but then we would need to depend on info-real, which would
+## but then we would need to depend on ${INFOS}, which would
## slow down parallelization.
${srcdir}/info/dir: ${info_dir_deps}
$(AM_V_at)${MKDIR_P} ${srcdir}/info
@@ -1082,24 +1075,6 @@ uninstall-html: $(UNINSTALL_HTML)
uninstall-pdf: $(UNINSTALL_PDF)
uninstall-ps: $(UNINSTALL_PS)
-
-# Note that man/Makefile knows how to put the info files in $(srcdir),
-# so we can do ok running make in the build dir.
-# This used to have a clause that exited with an error if MAKEINFO = no.
-# But it is inappropriate to do so without checking if makeinfo is
-# actually needed - it is not if the info files are up-to-date. (Bug#3982)
-# Only the doc/*/Makefiles can decide that, so we let those rules run
-# and give a standard error if makeinfo is needed but missing.
-# While it would be nice to give a more detailed error message, that
-# would require changing every rule in doc/ that builds an info file,
-# and it's not worth it. This case is only relevant if you download a
-# release, then change the .texi files.
-ifneq ($(HAVE_MAKEINFO),no)
-info: info-real info-dir
-else
-info:
-endif
-
## build-aux/make-info-dir expects only certain dircategories.
check-info: info
cd info ; \