summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorPeter Oliver <p.d.oliver@mavit.org.uk>2021-05-29 04:15:28 +0200
committerLars Ingebrigtsen <larsi@gnus.org>2021-05-29 04:15:28 +0200
commitee7752aac55468f06a71ea0e9ee0be0dff5b1f67 (patch)
tree8c87b6c84dafcd8ce736c81e34d5ad964719ac5c /Makefile.in
parent459f89f3bcbe5fb1a160b2d215154669343b78d9 (diff)
downloademacs-ee7752aac55468f06a71ea0e9ee0be0dff5b1f67.tar.gz
Rename emacs.appdata.xml to emacs.metainfo.xml and add more data
* Makefile.in: Replace "appdata" with "metainfo". This is the name currently recommended by the spec at <https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html>. * etc/emacs.metainfo.xml: Populate more fields, based on those available in https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html (bug#48662). Copyright-paperwork-exempt: yes
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.in b/Makefile.in
index 65eceb2a0c9..3facfa59a90 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -185,8 +185,8 @@ x_default_search_path=@x_default_search_path@
# Where the etc/emacs.desktop file is to be installed.
desktopdir=$(datarootdir)/applications
-# Where the etc/emacs.appdata.xml file is to be installed.
-appdatadir=$(datarootdir)/metainfo
+# Where the etc/emacs.metainfo.xml file is to be installed.
+metainfodir=$(datarootdir)/metainfo
# Where the etc/emacs.service file is to be installed.
# The system value (typically /usr/lib/systemd/user) can be
@@ -721,11 +721,11 @@ install-etc:
${srcdir}/etc/emacsclient.desktop > $${tmp}; \
${INSTALL_DATA} $${tmp} "$(DESTDIR)${desktopdir}/$${client_name}.desktop"; \
rm -f $${tmp}
- umask 022; ${MKDIR_P} "$(DESTDIR)${appdatadir}"
- tmp=etc/emacs.tmpappdata; rm -f $${tmp}; \
+ umask 022; ${MKDIR_P} "$(DESTDIR)${metainfodir}"
+ tmp=etc/emacs.tmpmetainfo; rm -f $${tmp}; \
sed -e "s/emacs\.desktop/${EMACS_NAME}.desktop/" \
- ${srcdir}/etc/emacs.appdata.xml > $${tmp}; \
- ${INSTALL_DATA} $${tmp} "$(DESTDIR)${appdatadir}/${EMACS_NAME}.appdata.xml"; \
+ ${srcdir}/etc/emacs.metainfo.xml > $${tmp}; \
+ ${INSTALL_DATA} $${tmp} "$(DESTDIR)${metainfodir}/${EMACS_NAME}.metainfo.xml"; \
rm -f $${tmp}
umask 022; $(MKDIR_P) "$(DESTDIR)$(systemdunitdir)"
tmp=etc/emacs.tmpservice; rm -f $${tmp}; \
@@ -811,7 +811,7 @@ uninstall: uninstall-$(NTDIR) uninstall-doc
"hicolor/scalable/mimetypes/${EMACS_NAME}-document23.svg"; \
fi)
-rm -f "$(DESTDIR)${desktopdir}/${EMACS_NAME}.desktop"
- -rm -f "$(DESTDIR)${appdatadir}/${EMACS_NAME}.appdata.xml"
+ -rm -f "$(DESTDIR)${metainfodir}/${EMACS_NAME}.metainfo.xml"
-rm -f "$(DESTDIR)$(systemdunitdir)/${EMACS_NAME}.service"
ifneq (,$(use_gamedir))
for file in snake-scores tetris-scores; do \