summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorPhilipp Stephani <phst@google.com>2018-09-20 14:03:29 +0200
committerEli Zaretskii <eliz@gnu.org>2018-10-16 18:43:18 +0300
commit1dce1b2ffb67907afff2cac62bb05361dac815e4 (patch)
tree897bc13b47792fc19aad2b001d5bcb4ee8b134fb /Makefile.in
parent73babba26aa714c34aa8d9473ba5b55ce110a215 (diff)
downloademacs-1dce1b2ffb67907afff2cac62bb05361dac815e4.tar.gz
Install emacs-module.h (Bug#31929)
* Makefile.in (includedir): New variable. (install-arch-indep): Install emacs-module.h. (uninstall): Uninstall emacs-module.h. (cherry picked from commit 00ea749f2af44bff6ea8c1259477fbf0ead8a306)
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index 19bf7c423ff..77498181650 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -151,6 +151,9 @@ libexecdir=@libexecdir@
# Currently only used for the systemd service file.
libdir=@libdir@
+# Where to install emacs-module.h.
+includedir=@includedir@
+
# Where to install Emacs's man pages.
# Note they contain cross-references that expect them to be in section 1.
mandir=@mandir@
@@ -558,6 +561,8 @@ set_installuser=for installuser in $${LOGNAME} $${USERNAME} $${USER} \
## See also these comments from 2004 about cp -r working fine:
## https://lists.gnu.org/r/autoconf-patches/2004-11/msg00005.html
install-arch-indep: lisp install-info install-man ${INSTALL_ARCH_INDEP_EXTRA}
+ umask 022 && $(MKDIR_P) -m 0755 $(includedir)
+ $(INSTALL_DATA) src/emacs-module.h $(includedir)/emacs-module.h
-set ${COPYDESTS} ; \
unset CDPATH; \
$(set_installuser); \
@@ -741,6 +746,7 @@ install-strip:
###
### Don't delete the lisp and etc directories if they're in the source tree.
uninstall: uninstall-$(NTDIR) uninstall-doc
+ rm -f $(includedir)/emacs-module.h
$(MAKE) -C lib-src uninstall
-unset CDPATH; \
for dir in "$(DESTDIR)${lispdir}" "$(DESTDIR)${etcdir}" ; do \