summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2018-09-24 10:44:34 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2018-09-24 10:45:07 -0700
commit36243179695a1711308e1d2f57c9ff847f3ef2d0 (patch)
treea89e0bad3013bc6787bdc20ecbebe59838009d89 /Makefile.in
parent662bee7d70ccd3903e123b08c7ec9108a1a2ce0b (diff)
downloademacs-36243179695a1711308e1d2f57c9ff847f3ef2d0.tar.gz
Fix ‘make clean’ with a file named ‘-.o’
Problem reported by T.V Raman in: https://lists.gnu.org/r/emacs-devel/2018-09/msg00866.html * Makefile.in (clean, extraclean): * doc/emacs/Makefile.in (mostlyclean): * doc/lispintro/Makefile.in (mostlyclean): * doc/lispref/Makefile.in (mostlyclean): * doc/misc/Makefile.in (mostlyclean, clean): * etc/refcards/Makefile (clean): * lib-src/Makefile.in (mostlyclean, extraclean): * lib/Makefile.in (clean): * lwlib/Makefile.in (clean mostlyclean): * oldXMenu/Makefile.in (clean mostlyclean): * src/Makefile.in (mostlyclean, extraclean): * test/Makefile.in (mostlyclean): Say ‘rm ./*.o’ instead of ‘rm *.o’ to avoid undesirable failure when a file name begins with ‘-’.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 5ea48824bd3..c6b2cfa78af 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -839,7 +839,7 @@ $(foreach dir,$(clean_dirs),$(eval $(call submake_template,$(dir),clean)))
clean: $(clean_dirs:=_clean)
$(MAKE) -C admin/charsets $@
[ ! -d test ] || $(MAKE) -C test $@
- -rm -f *.tmp etc/*.tmp*
+ -rm -f ./*.tmp etc/*.tmp*
-rm -rf info-dir.*
### 'bootclean'
@@ -926,7 +926,7 @@ $(foreach dir,$(extraclean_dirs),$(eval $(call submake_template,$(dir),extraclea
extraclean: $(extraclean_dirs:=_extraclean)
${top_maintainer_clean}
-rm -f config-tmp-*
- -rm -f *~ \#*
+ -rm -f ./*~ \#*
# The src subdir knows how to do the right thing
# even when the build directory and source dir are different.