summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorPhillip Lord <phillip.lord@russet.org.uk>2017-03-07 13:25:45 +0000
committerPhillip Lord <phillip.lord@russet.org.uk>2017-03-07 13:49:48 +0000
commit542a763281347b026b6714483299a108a8c3b9c2 (patch)
tree409e48faaec350983a446e450c9b434e14c5958e /Makefile.in
parente37bfd41546f515cfef1f8d2c64df2dccac18a86 (diff)
downloademacs-542a763281347b026b6714483299a108a8c3b9c2.tar.gz
Revert "Replace ldefs-boot with a much smaller file"
This reverts commit c27b645956a11fab1dd8fa189254d525390958f5. This commit has been reverted because the new mechanism was too sensitive to changes in the lisp source, generation of new ldefs-boot files was platform specific and resulted in warnings about undefined variables. See also 11436e2890d.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in19
1 files changed, 1 insertions, 18 deletions
diff --git a/Makefile.in b/Makefile.in
index 2cc41feb462..82fb91fd9cd 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1120,9 +1120,7 @@ check-info: info
# * Run autogen.sh.
# * Rebuild Makefile, to update the build procedure itself.
# * Do the actual build.
-bootstrap: | bootstrap-clean bootstrap-build
-
-bootstrap-build:
+bootstrap: bootstrap-clean
cd $(srcdir) && ./autogen.sh
$(MAKE) MAKEFILE_NAME=force-Makefile force-Makefile
$(MAKE) all
@@ -1185,18 +1183,3 @@ check-declare:
exit 1; \
fi
$(MAKE) -C lisp $@
-
-## Generating ldefs-boot-auto.el requires a completely clean build so
-## that we can see which autoloads are actually called. The build has
-## to complete because we use Emacs to clean the results up! We use
-## loaddefs.el in place of ldefs-boot-auto, because if we are running
-## this there is the possibility that ldefs-boot-auto is not
-## sufficient for bootstrap.
-generate-ldefs-boot: all
- echo "Generating Bootstrap ldefs"
- cp lisp/loaddefs.el lisp/ldefs-boot-auto.el
- $(MAKE) -j 1 bootstrap \
- GENERATE_LDEFS_BOOT="generate-ldefs-boot" \
- 2>&1 | tee lisp/ldefs-boot-auto.temp
- $(EMACS) -batch --load admin/ldefs-clean.el --funcall ldefs-clean
- rm lisp/ldefs-boot-auto.temp