summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-03-27 11:22:54 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2017-03-27 11:30:08 -0700
commit55086ef6517bd7294783d08d2b3cd50c330a9e96 (patch)
tree9d06a6909dd620aa6ab26546b5b86c7dd36d9d91 /Makefile.in
parent8ce827426e5400f2be80ae5d7394b74d8dd90373 (diff)
downloademacs-55086ef6517bd7294783d08d2b3cd50c330a9e96.tar.gz
Fix obsolete ‘test/automated’ references
* Makefile.in (mostlyclean, clean, maybeclean_dirs, distclean) (bootstrap-clean, maintainer-clean): Clean ‘test’, not ‘test/automated’. Test for existence of subdirectory only for ‘test’, not for directories that should always exist. * admin/MAINTAINERS, etc/TODO, lisp/emacs-lisp/bytecomp.el: * lisp/emacs-lisp/seq.el, lisp/emacs-lisp/thunk.el: * lisp/man.el (Man-parse-man-k): * lisp/url/url-domsuf.el, make-dist: * test/file-organization.org: Fix obsolete references to test/automated.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in26
1 files changed, 13 insertions, 13 deletions
diff --git a/Makefile.in b/Makefile.in
index cf8ff84212f..06909c34445 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -821,9 +821,7 @@ mostlyclean_dirs = src oldXMenu lwlib lib lib-src nt doc/emacs doc/misc \
$(foreach dir,$(mostlyclean_dirs),$(eval $(call submake_template,$(dir),mostlyclean)))
mostlyclean: $(mostlyclean_dirs:=_mostlyclean)
- for dir in test/automated; do \
- [ ! -d $$dir ] || $(MAKE) -C $$dir mostlyclean; \
- done
+ [ ! -d test ] || $(MAKE) -C test $@
### 'clean'
### Delete all files from the current directory that are normally
@@ -838,9 +836,8 @@ clean_dirs = $(mostlyclean_dirs) nextstep
$(foreach dir,$(clean_dirs),$(eval $(call submake_template,$(dir),clean)))
clean: $(clean_dirs:=_clean)
- for dir in test/automated admin/charsets; do \
- [ ! -d $$dir ] || $(MAKE) -C $$dir clean; \
- done
+ $(MAKE) -C admin/charsets $@
+ [ ! -d test ] || $(MAKE) -C test $@
-rm -f *.tmp etc/*.tmp*
-rm -rf info-dir.*
@@ -864,12 +861,13 @@ distclean_dirs = $(clean_dirs) leim lisp
$(foreach dir,$(distclean_dirs),$(eval $(call submake_template,$(dir),distclean)))
-maybeclean_dirs = test/automated admin/grammars admin/unidata admin/charsets
+maybeclean_dirs = test admin/grammars admin/unidata admin/charsets
distclean: $(distclean_dirs:=_distclean)
- for dir in ${maybeclean_dirs}; do \
- [ ! -d $$dir ] || $(MAKE) -C $$dir distclean; \
+ for dir in $(filter-out test,$(maybeclean_dirs)); do \
+ $(MAKE) -C $$dir $@ || exit; \
done
+ [ ! -d test ] || $(MAKE) -C test $@
${top_distclean}
### 'bootstrap-clean'
@@ -878,9 +876,10 @@ distclean: $(distclean_dirs:=_distclean)
$(foreach dir,$(distclean_dirs),$(eval $(call submake_template,$(dir),bootstrap-clean)))
bootstrap-clean: $(distclean_dirs:=_bootstrap-clean)
- for dir in ${maybeclean_dirs}; do \
- [ ! -d $$dir ] || $(MAKE) -C $$dir bootstrap-clean; \
+ for dir in $(filter-out test,$(maybeclean_dirs)); do \
+ $(MAKE) -C $$dir $@ || exit; \
done
+ [ ! -d test ] || $(MAKE) -C test $@
[ ! -f config.log ] || mv -f config.log config.log~
rm -rf ${srcdir}/info
rm -f ${srcdir}/etc/refcards/emacsver.tex
@@ -906,9 +905,10 @@ maintainer_clean_dirs = src leim lisp
$(foreach dir,$(maintainer_clean_dirs),$(eval $(call submake_template,$(dir),maintainer-clean)))
maintainer-clean: bootstrap-clean $(maintainer_clean_dirs:=_maintainer-clean)
- for dir in ${maybeclean_dirs}; do \
- [ ! -d $$dir ] || $(MAKE) -C $$dir maintainer-clean; \
+ for dir in $(filter-out test,$(maybeclean_dirs)); do \
+ $(MAKE) -C $$dir $@ || exit; \
done
+ [ ! -d test ] || $(MAKE) -C test $@
${top_maintainer_clean}
### This doesn't actually appear in the coding standards, but Karl