summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-08-02 13:01:58 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2017-08-02 13:03:03 -0700
commit5ed0bf1061cb0b2e70ee1d28f5f3586259ec0f3b (patch)
tree8c5d1b2ba87e8190875ac92edb228c0aebde7643 /Makefile.in
parentfe80d58ca4ead89e8887aa726482694888a8ef7f (diff)
downloademacs-5ed0bf1061cb0b2e70ee1d28f5f3586259ec0f3b.tar.gz
Clarify when autogen.sh should run only autoconf
* Makefile.in (configure, bootstrap): Run ‘./autogen.sh autoconf’, not plain ‘./autogen.sh’, to make it clear that only autoconf-related tools should be run here.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index a31d416bd74..8a08465c4a9 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -448,7 +448,7 @@ config.status: ${srcdir}/configure
fi
$(srcdir)/configure: $(srcdir)/configure.ac $(srcdir)/m4/*.m4
- cd $(srcdir) && ./autogen.sh
+ cd $(srcdir) && ./autogen.sh autoconf
# ==================== Installation ====================
@@ -1094,7 +1094,7 @@ check-info: info
# * Rebuild Makefile, to update the build procedure itself.
# * Do the actual build.
bootstrap: bootstrap-clean
- cd $(srcdir) && ./autogen.sh
+ cd $(srcdir) && ./autogen.sh autoconf
$(MAKE) MAKEFILE_NAME=force-Makefile force-Makefile
$(MAKE) all