summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorPhillip Lord <phillip.lord@russet.org.uk>2017-03-07 13:22:18 +0000
committerPhillip Lord <phillip.lord@russet.org.uk>2017-03-07 13:48:20 +0000
commit8f58747a878941661e2f0f667e18620cf9b632ff (patch)
tree713bec88630b060340bae9859694505fb60745ae /Makefile.in
parent11436e2890fda7367936b63b8fe2daca6957d3ef (diff)
downloademacs-8f58747a878941661e2f0f667e18620cf9b632ff.tar.gz
Revert "Speed generation of ldefs-boot-auto"
This reverts commit 7b5e1c8238ef961fd3305b1dce053b9bced684ba. This commit has been reverted because the new mechanism was too sensitive to changes in the lisp source, generation of new ldefs-boot files was platform specific and resulted in warnings about undefined variables. See also 11436e2890d.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in17
1 files changed, 14 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index a7b122f5188..2cc41feb462 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1186,6 +1186,17 @@ check-declare:
fi
$(MAKE) -C lisp $@
-generate-ldefs-boot:
- echo "Generating ldefs-boot-auto.el"
- $(MAKE) -C src generate-ldefs-boot
+## Generating ldefs-boot-auto.el requires a completely clean build so
+## that we can see which autoloads are actually called. The build has
+## to complete because we use Emacs to clean the results up! We use
+## loaddefs.el in place of ldefs-boot-auto, because if we are running
+## this there is the possibility that ldefs-boot-auto is not
+## sufficient for bootstrap.
+generate-ldefs-boot: all
+ echo "Generating Bootstrap ldefs"
+ cp lisp/loaddefs.el lisp/ldefs-boot-auto.el
+ $(MAKE) -j 1 bootstrap \
+ GENERATE_LDEFS_BOOT="generate-ldefs-boot" \
+ 2>&1 | tee lisp/ldefs-boot-auto.temp
+ $(EMACS) -batch --load admin/ldefs-clean.el --funcall ldefs-clean
+ rm lisp/ldefs-boot-auto.temp