summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2018-06-21 13:29:15 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2018-06-21 13:30:23 -0700
commit9a27310f0ab068bef52cfe30d3abc5eda3a0d12b (patch)
treecf906ad8760b832e7a6ce3772bc205a0a14833d9 /Makefile.in
parent5583e6460c38c5d613e732934b066421349a5259 (diff)
downloademacs-9a27310f0ab068bef52cfe30d3abc5eda3a0d12b.tar.gz
Set group when installing, too
From a patch by Ulrich Mueller in: https://lists.gnu.org/r/emacs-devel/2018-06/msg00687.html * Makefile.in (set_installuser): Also set the group, in order to match install(1) behavior. Also, don’t clutter stderr with a diagnostic if ‘id’ is missing.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 52d44d9708f..4d7627ba09d 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -516,9 +516,11 @@ INSTALL_ARCH_INDEP_EXTRA = @INSTALL_ARCH_INDEP_EXTRA@
## https://lists.gnu.org/r/emacs-devel/2007-10/msg01672.html
## Needs to be the user running install, so configure can't set it.
set_installuser=for installuser in $${LOGNAME} $${USERNAME} $${USER} \
- `id -un 2> /dev/null`; do \
+ `(id -u) 2> /dev/null`; do \
[ -n "$${installuser}" ] && break ; \
- done
+ done; \
+ installgroup=`(id -g) 2>/dev/null` && [ -n "$$installgroup" ] && \
+ installuser=$$installuser:$$installgroup
### Install the files that are machine-independent.
### Most of them come straight from the distribution; the exception is