summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2018-01-15 13:53:40 -0800
committerGlenn Morris <rgm@gnu.org>2018-01-15 13:53:40 -0800
commit9bd8f01cd6613795e6a7bb228b1aff342cc88c8b (patch)
treeaa566ea564a3d8e344c3015b997a6478e2010b5d /Makefile.in
parente6b1df09551fc02aedcba4dbf5ee91dad4686e9a (diff)
parent2c0cfa64553dc1d4d376b42b56e52a007222736b (diff)
downloademacs-9bd8f01cd6613795e6a7bb228b1aff342cc88c8b.tar.gz
Merge from origin/emacs-26
2c0cfa6455 * ChangeLog.3: Update 4387bb44ae Update authors bce51bd6f7 * lisp/gnus/message.el (message-do-auto-fill): Prevent do-... bd2a2a1e84 Improve documentation of etags 7ba75b9637 Teach etags new interpreters for some languages 1f7f03742d * lisp/emacs-lisp/generator.el (iter-defun): Add 'doc-stri... dbb4aac212 * lisp/emacs-lisp/syntax.el (syntax-propertize): Fix bug#2... 80463a43da Improve documentation of fill-separate-heterogeneous-words... 4bd2416d55 Fix documentation of some x-* functions 9c2b11484f Inherit query-on-exit flag to stderr process (Bug#30031) 3efb1e7def Fix Bug#30057 a9b884c60f Tag some unstable tests, and skip by default (bug#24503) # Conflicts: # test/lisp/emacs-lisp/eieio-tests/eieio-tests.el
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.in b/Makefile.in
index 009c51a291d..66369cd25f4 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -58,9 +58,11 @@
# make docs
# Make Emacs documentation files from their sources; requires makeinfo.
#
-# make check or make check-expensive
-# Run Emacs test suite. check-expensive runs also tests which
-# take more time to perform.
+# make check (or check-expensive or check-all)
+# Run the Emacs test suite.
+# check-expensive includes additional tests that can be slow.
+# check-all runs all tests, including ones that can be slow, or
+# fail unpredictably
SHELL = @SHELL@
@@ -938,7 +940,8 @@ have-tests:
exit 1; \
fi
-check check-maybe check-expensive: have-tests all
+.PHONY: check check-maybe check-expensive check-all
+check check-maybe check-expensive check-all: have-tests all
$(MAKE) -C test $@
dist:
@@ -955,7 +958,7 @@ $(DOCS):
$(MAKE) -C doc/$(subst -, ,$@)
.PHONY: $(DOCS) docs pdf ps
-.PHONY: info dvi dist check check-maybe check-expensive html info-real info-dir check-info
+.PHONY: info dvi dist html info-real info-dir check-info
## TODO add etc/refcards.
docs: $(DOCS)