summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2017-02-18 14:49:30 +0200
committerEli Zaretskii <eliz@gnu.org>2017-02-18 14:49:30 +0200
commitba6e7232d0324a52be4cd5d5cd3da93ca651ebda (patch)
tree24c3d3fecf96e248621a65a3db627d6dd39f0973 /Makefile.in
parenta848d36c578cb849a283d72edbd69d1b955350f9 (diff)
downloademacs-ba6e7232d0324a52be4cd5d5cd3da93ca651ebda.tar.gz
Automatically regenerate emacs.1 and *.rc files
* Makefile.in (CONFIG_STATUS_FILES_IN): New variable, lists non-Makefile files produced by config.status. ($(MAKEFILE_NAME)): Depend on $(CONFIG_STATUS_FILES_IN), so that their targets are regenerated when the source changes.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 807a40a2844..2cc41feb462 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -307,6 +307,11 @@ SUBDIR = $(NTDIR) lib lib-src src lisp
SUBDIR_MAKEFILES_IN = @SUBDIR_MAKEFILES_IN@
SUBDIR_MAKEFILES = $(patsubst ${srcdir}/%,%,${SUBDIR_MAKEFILES_IN:.in=})
+# Non-makefile files created by config.status.
+CONFIG_STATUS_FILES_IN = \
+ ${srcdir}/nt/emacs.rc.in ${srcdir}/nt/emacsclient.rc.in \
+ ${srcdir}/doc/man/emacs.1.in
+
# Subdirectories to install, and where they'll go. lib-src's and nt's
# makefiles know how to install them, so we don't do that here.
# Directories that cannot simply be copied, eg info, are treated
@@ -424,7 +429,7 @@ blessmail: Makefile src
# etc. to be built without running into similar recursion problems.
MAKEFILE_NAME = Makefile
$(MAKEFILE_NAME): config.status $(srcdir)/src/config.in \
- $(srcdir)/Makefile.in $(SUBDIR_MAKEFILES_IN)
+ $(srcdir)/Makefile.in $(SUBDIR_MAKEFILES_IN) $(CONFIG_STATUS_FILES_IN)
MAKE='$(MAKE)' ./config.status
# Don't erase these files if make is interrupted while refreshing them.