summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2018-10-03 16:47:01 -0400
committerGlenn Morris <rgm@gnu.org>2018-10-03 16:47:01 -0400
commitc1d0dbd6ca92cb221024382b19654e4fbf1d1ed3 (patch)
tree671410fa71ca5762893bb8ef4e3bd5767c5a0085 /Makefile.in
parent00ea749f2af44bff6ea8c1259477fbf0ead8a306 (diff)
downloademacs-c1d0dbd6ca92cb221024382b19654e4fbf1d1ed3.tar.gz
Tweak Makefile emacs-module.h handling
* Makefile.in (install-arch-indep, uninstall): Respect DESTDIR. Handle whitespace. Remove non-portable mkdir argument.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index e10fdc3bd69..d8d345e8059 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -563,8 +563,8 @@ set_installuser=for installuser in $${LOGNAME} $${USERNAME} $${USER} \
## See also these comments from 2004 about cp -r working fine:
## https://lists.gnu.org/r/autoconf-patches/2004-11/msg00005.html
install-arch-indep: lisp install-info install-man ${INSTALL_ARCH_INDEP_EXTRA}
- umask 022 && $(MKDIR_P) -m 0755 $(includedir)
- $(INSTALL_DATA) src/emacs-module.h $(includedir)/emacs-module.h
+ umask 022 && $(MKDIR_P) "$(DESTDIR)$(includedir)"
+ $(INSTALL_DATA) src/emacs-module.h "$(DESTDIR)$(includedir)/emacs-module.h"
-set ${COPYDESTS} ; \
unset CDPATH; \
$(set_installuser); \
@@ -748,7 +748,7 @@ install-strip:
###
### Don't delete the lisp and etc directories if they're in the source tree.
uninstall: uninstall-$(NTDIR) uninstall-doc
- rm -f $(includedir)/emacs-module.h
+ rm -f "$(DESTDIR)$(includedir)/emacs-module.h"
$(MAKE) -C lib-src uninstall
-unset CDPATH; \
for dir in "$(DESTDIR)${lispdir}" "$(DESTDIR)${etcdir}" ; do \