summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-02-06 18:00:13 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2017-02-06 18:04:50 -0800
commitd7134989be3a83927e178bf0063aa5237bdb2a18 (patch)
treedc5de5eff4c99d51c9a6fd57d4529c24f4eb43d6 /Makefile.in
parent03a012a79679c730634537f966200878bfd1c0b4 (diff)
downloademacs-d7134989be3a83927e178bf0063aa5237bdb2a18.tar.gz
Do not trick info/dir’s timestamp
* Makefile.in (${srcdir}/info/dir): When making this file, do not do anything special about its timestamp. Previously this rule used move-if-change, which meant that this file’s timestamp could end up being older than the files it depends on, and this caused ‘make --question info’ to fail, which caused ‘make-dist’ to fail now that ‘make-dist’ invokes ‘make --question info’.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile.in b/Makefile.in
index 60f30b993a3..807a40a2844 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1011,12 +1011,10 @@ info_dir_deps = \
## slow down parallelization.
${srcdir}/info/dir: ${info_dir_deps}
$(AM_V_at)${MKDIR_P} ${srcdir}/info
- $(AM_V_GEN)tempfile=info-dir.$$$$; \
- rm -f $${tempfile}; \
- (cd ${srcdir}/doc && \
+ $(AM_V_GEN)(cd ${srcdir}/doc && \
AWK='${AWK}' ../build-aux/make-info-dir ${info_dir_inputs} \
- ) >$$tempfile && \
- ${srcdir}/build-aux/move-if-change $${tempfile} ${srcdir}/info/dir
+ ) >$@.tmp
+ mv $@.tmp $@
INSTALL_DVI = install-emacs-dvi install-lispref-dvi \
install-lispintro-dvi install-misc-dvi