summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorStefan Monnier <monnier@iro.umontreal.ca>2019-01-23 16:02:11 -0500
committerStefan Monnier <monnier@iro.umontreal.ca>2019-01-23 16:02:11 -0500
commitdbc48d758ac90748df4befc677b2d21c5cd06d3b (patch)
treeeb57b8ec0c5ef3ef9ac216b4f8821aa48e1246f4 /Makefile.in
parent191394276a4c455edd65e7f827fe8bc8317e8348 (diff)
downloademacs-dbc48d758ac90748df4befc677b2d21c5cd06d3b.tar.gz
Avoid having to build src/emacs when we just want to `make tags`
* Makefile.in (TAGS tags): Remove `src` from the dependencies. * src/Makefile.in (ctagsfiles1): Strip macuvs.h and fingerprint.c.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index b6cd04d1f3d..53703638c42 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -944,7 +944,9 @@ extraclean: $(extraclean_dirs:=_extraclean)
# The src subdir knows how to do the right thing
# even when the build directory and source dir are different.
.PHONY: TAGS tags
-TAGS tags: lib lib-src src
+# FIXME: We used to include `src` in the dependencies, not sure why.
+# I removed it because it causes `make tags` to build Emacs.
+TAGS tags: lib lib-src # src
$(MAKE) -C src tags
.PHONY: have-tests