summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorLars Ingebrigtsen <larsi@gnus.org>2019-06-20 17:04:04 +0200
committerLars Ingebrigtsen <larsi@gnus.org>2019-06-20 17:04:04 +0200
commitde4e1bddb1c4823af4d04f0bff5b4a0217e9701d (patch)
tree856433079bfe755b0f026c0c2744522414f3b0c5 /Makefile.in
parent756c48b33fc501003fb46598ed44c8a701c7a4df (diff)
downloademacs-de4e1bddb1c4823af4d04f0bff5b4a0217e9701d.tar.gz
Make extraclean return tree to pristine state by deleting more
* src/Makefile.in (extraclean): Remove TAGS and config.in. * Makefile.in (extraclean): Remove info, configure and emacsver.texi in extraclean. * admin/unidata/Makefile.in (extraclean): Make it depend on distclean to remove .elc files. * leim/Makefile.in (extraclean): Depend on bootstrap-clean to remove generated .el files. * lib/Makefile.in (extraclean): Added target to remove sys directory and run distclean. * lisp/Makefile.in (extraclean): Also remove loaddefs*.el~ files.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index 21362a91963..5e23d72419e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -933,14 +933,16 @@ maintainer-clean: bootstrap-clean $(maintainer_clean_dirs:=_maintainer-clean)
### Note that we abuse this in some subdirectories (eg leim),
### to delete some generated files that are slow to rebuild.
extraclean_dirs = ${NTDIR} lib-src src leim \
- admin/charsets admin/grammars admin/unidata
+ admin/charsets admin/grammars admin/unidata lisp lib
$(foreach dir,$(extraclean_dirs),$(eval $(call submake_template,$(dir),extraclean)))
extraclean: $(extraclean_dirs:=_extraclean)
${top_maintainer_clean}
- -rm -f config-tmp-*
- -rm -f ./*~ \#*
+ -rm -f config-tmp-* aclocal.m4 configure
+ -rm -f ./*~ \#* etc/refcards/emacsver.tex doc/emacs/emacsver.texi
+ -rm -f info/*.info info/dir
+ -[ -d info ] && rmdir --ignore-fail-on-non-empty info
# The src subdir knows how to do the right thing
# even when the build directory and source dir are different.