summaryrefslogtreecommitdiff
path: root/admin/check-doc-strings
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2016-01-24 17:27:52 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2016-01-24 17:29:01 -0800
commit6475f9265ecf21a8d49bc3ac0dc66010c9ec6b05 (patch)
tree63a676fa6aa05757206bc5fbd519895e5624dc65 /admin/check-doc-strings
parent2f505ff7928a513ad7f30b9b7074e0d6d1436378 (diff)
downloademacs-6475f9265ecf21a8d49bc3ac0dc66010c9ec6b05.tar.gz
Port "$@" to OpenIndiana ksh93
In http://lists.gnu.org/archive/html/bug-autoconf/2015-12/msg00000.html Pavel Raiskup reports that ${1+"$@"} runs afoul of a bug in /bin/sh (derived from ksh 93t+ 2010-03-05). ${1+"$@"} works around an ancient bug in long-dead shells, so remove the workaround. * admin/check-doc-strings, configure.ac, lib-src/rcs2log: Use plain "$@" rather than ${1+"$@"}.
Diffstat (limited to 'admin/check-doc-strings')
-rwxr-xr-xadmin/check-doc-strings3
1 files changed, 1 insertions, 2 deletions
diff --git a/admin/check-doc-strings b/admin/check-doc-strings
index 13e8b0cd8e7..63856d32871 100755
--- a/admin/check-doc-strings
+++ b/admin/check-doc-strings
@@ -1,5 +1,5 @@
: #-*- Perl -*-
-eval 'exec perl -S $0 ${1+"$@"}' # Portability kludge
+eval 'exec perl -S $0 "$@"' # Portability kludge
if 0;
# Author: Martin Buchholz
@@ -299,4 +299,3 @@ foreach my $fun (sort keys %texi_funtype) {
print "nuke-this-doc: $fun $texi_funtype{$fun}\n";
}
}
-