summaryrefslogtreecommitdiff
path: root/admin/make-tarball.txt
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2015-04-07 00:00:55 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2015-04-07 00:00:55 -0700
commit23468561682aea0705249a469f614bb873e4f411 (patch)
tree0f9627efff11eaec69cbe91a730ccfdda2f1396e /admin/make-tarball.txt
parentdd1404cca3cf6bc459bc53f9aa9528170e30efd4 (diff)
downloademacs-23468561682aea0705249a469f614bb873e4f411.tar.gz
Generate a ChangeLog file from commit logs
* .gitignore: Add 'ChangeLog'. * build-aux/gitlog-to-changelog: New file, from Gnulib. * build-aux/gitlog-to-emacslog: New file. * CONTRIBUTE: Document the revised workflow. * Makefile.in (clean): Remove *.tmp and etc/*.tmp* instead of just special cases. (CHANGELOG_HISTORY_INDEX_MAX, CHANGELOG_N, gen_origin): New vars. (ChangeLog, unchanged-history-files, change-history) (change-history-commit): New rules. * admin/admin.el (make-manuals-dist--1): Don't worry about doc/ChangeLog. * admin/authors.el: Add a FIXME. * admin/make-tarball.txt: * lisp/calendar/icalendar.el: * lisp/gnus/deuglify.el: * lisp/obsolete/gulp.el: * lwlib/README: Adjust to renamed ChangeLog history files. * admin/merge-gnulib (GNULIB_MODULES): Add gitlog-to-changelog. * admin/notes/repo: Call it 'master' a la Git, not 'trunk' a la Bzr. Remove obsolete discussion of merging ChangeLog files. New section "Maintaining ChangeLog history". * build-aux/git-hooks/pre-commit: Reject attempts to commit files named 'ChangeLog'. * lib/gnulib.mk, m4/gnulib-comp.m4: Regenerate. * make-dist: Make and distribute top-level ChangeLog if there's a .git directory. Distribute the new ChangeLog history files instead of scattered ChangeLog files. Distribute the new files gitlog-to-changelog and gitlog-to-emacslog. Fixes: bug#19113
Diffstat (limited to 'admin/make-tarball.txt')
-rw-r--r--admin/make-tarball.txt24
1 files changed, 14 insertions, 10 deletions
diff --git a/admin/make-tarball.txt b/admin/make-tarball.txt
index e902b023f80..8190e9edb85 100644
--- a/admin/make-tarball.txt
+++ b/admin/make-tarball.txt
@@ -31,28 +31,33 @@ General steps (for each step, check for possible errors):
M-x authors RET
If there is an "*Authors Errors*" buffer, address the issues.
- If there was a ChangeLog typo, fix it. If a file was deleted or
- renamed, consider adding an appropriate entry to authors-ignored-files,
- authors-valid-file-names, or authors-renamed-files-alist.
+ If there was a ChangeLog typo, run "make change-history" and then
+ fix the newest ChangeLog history file. If a file was deleted or
+ renamed, consider adding an appropriate entry to
+ authors-ignored-files, authors-valid-file-names, or
+ authors-renamed-files-alist.
If necessary, repeat M-x authors after making those changes.
Save the "*Authors*" buffer as etc/AUTHORS.
Check the diff looks reasonable. Maybe add entries to
authors-ambiguous-files or authors-aliases, and repeat.
- Commit any fixes to ChangeLogs or authors.el.
+ Commit any fixes to authors.el.
3. Set the version number (M-x load-file RET admin/admin.el RET, then
M-x set-version RET). For a release, add released ChangeLog
- entries (M-x add-release-logs RET).
+ entries (create a ChangeLog symlink a la vc-dwim, then run M-x
+ add-release-logs RET, then run the shell command 'vc-dwim --commit').
For a pretest, start at version .90. After .99, use .990 (so that
it sorts).
The final pretest should be a release candidate. Set the version
number to that of the actual release. Pick a date about a week
- from now when you intend to make the release. Use M-x add-release-logs
- to add the ChangeLog entries for that date to the tar file (but
- do not commit the entries to the repository until the actual release).
+ from now when you intend to make the release. Use vc-dwim and
+ M-x add-release-logs as described above to add commit messages
+ that will appear in the tarball's automatically-generated ChangeLog
+ file as entries for that date.
+
Name the tar file as emacs-XX.Y-rc1.tar. If all goes well in the
following week, you can simply rename the file and use it for the
actual release. If you need another release candidate, remember
@@ -67,8 +72,7 @@ General steps (for each step, check for possible errors):
5. Copy lisp/loaddefs.el to lisp/ldefs-boot.el.
Commit etc/AUTHORS, lisp/ldefs-boot.el, and the files changed
- by M-x set-version. For a release, also commit the ChangeLog
- files in all directories.
+ by M-x set-version.
If someone else made a commit between step 1 and now,
you need to repeat from step 4 onwards. (You can commit the files