summaryrefslogtreecommitdiff
path: root/admin/update_autogen
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2014-01-10 13:59:54 -0500
committerGlenn Morris <rgm@gnu.org>2014-01-10 13:59:54 -0500
commitcd6d07ece2278b315852e20f07cfea05bd5bd29b (patch)
tree653d26f21a929b9a7a798735b86d884896f466f9 /admin/update_autogen
parentb4256e8c52981cf8a9674fbadb81082f8d30c4c5 (diff)
downloademacs-cd6d07ece2278b315852e20f07cfea05bd5bd29b.tar.gz
* admin/update_autogen: Fix sed bug that was losing the last AUTOGEN_VCS.
Diffstat (limited to 'admin/update_autogen')
-rwxr-xr-xadmin/update_autogen5
1 files changed, 3 insertions, 2 deletions
diff --git a/admin/update_autogen b/admin/update_autogen
index 171674fb784..02b15c3aaa1 100755
--- a/admin/update_autogen
+++ b/admin/update_autogen
@@ -317,8 +317,9 @@ EOF
echo "Finding loaddef targets..."
-sed -n -e '/^AUTOGEN_VCS/,/^$/ s/\\//p' lisp/Makefile.in | \
- sed '/AUTOGEN_VCS/d' >| $tempfile || die "sed error"
+sed -n -e '/^AUTOGEN_VCS/,/^$/p' lisp/Makefile.in | \
+ sed -e '/AUTOGEN_VCS/d' -e '/^$/d' -e 's/\\//' \
+ >| $tempfile || die "sed error"
genfiles=