summaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2022-07-05 23:25:44 -0500
committerPaul Eggert <eggert@cs.ucla.edu>2022-07-05 23:27:17 -0500
commit54e0b14a6981a317210493f0fead1e2c5b6508ea (patch)
tree4d6f3c5b45a31ff56f76a6d4c9184024962968af /admin
parente482379a65e99cb61aba86876587b499eeeef007 (diff)
downloademacs-54e0b14a6981a317210493f0fead1e2c5b6508ea.tar.gz
Adjust better to Autoconf quoting style change
* admin/gitmerge.el (gitmerge-emacs-version): * admin/nt/dist-build/build-zips.sh (ACTUAL_VERSION): * admin/quick-install-emacs (VERSION): * lisp/cedet/ede/emacs.el (ede-emacs-version): Adjust to change in configure.ac’s Autoconf quoting style. * etc/srecode/ede-autoconf.srt: * test/lisp/progmodes/autoconf-tests.el: (autoconf-tests-current-defun-function-define) (autoconf-tests-current-defun-function-subst): Use better Autoconf quoting. * make-dist (version): Simplify.
Diffstat (limited to 'admin')
-rw-r--r--admin/gitmerge.el2
-rwxr-xr-xadmin/nt/dist-build/build-zips.sh2
-rwxr-xr-xadmin/quick-install-emacs4
3 files changed, 4 insertions, 4 deletions
diff --git a/admin/gitmerge.el b/admin/gitmerge.el
index 5da70a40285..a214dcbcb74 100644
--- a/admin/gitmerge.el
+++ b/admin/gitmerge.el
@@ -124,7 +124,7 @@ If nil, the function `gitmerge-default-branch' guesses.")
(let ((coding-system-for-read vc-git-log-output-coding-system))
(call-process "git" nil t nil "show" (format "%s:configure.ac" branch)))
(goto-char (point-min)))
- (re-search-forward "^AC_INIT([^,]+, \\([0-9]+\\)\\.")
+ (re-search-forward "^AC_INIT([^,]+, \\[?\\([0-9]+\\)\\.")
(string-to-number (match-string 1))))
(defun gitmerge-default-branch ()
diff --git a/admin/nt/dist-build/build-zips.sh b/admin/nt/dist-build/build-zips.sh
index 77d20a5a7b9..39ac1fde604 100755
--- a/admin/nt/dist-build/build-zips.sh
+++ b/admin/nt/dist-build/build-zips.sh
@@ -148,7 +148,7 @@ done
if [ -z $ACTUAL_VERSION ];
then
ACTUAL_VERSION=`
- sed -n 's/^AC_INIT(GNU Emacs,[ ]*\([^ ,)]*\).*/\1/p' < ../../../configure.ac
+ sed -n 's/^AC_INIT(\[*GNU Emacs]*,[ ]*\[*\([^] ,)]*\).*/\1/p' < ../../../configure.ac
`
fi
diff --git a/admin/quick-install-emacs b/admin/quick-install-emacs
index 9a73cf5a401..b0a1d342518 100755
--- a/admin/quick-install-emacs
+++ b/admin/quick-install-emacs
@@ -172,10 +172,10 @@ test x"$prefix" = x && { prefix="`get_config_var prefix`" || exit 4 ; }
test x"$ARCH" = x && { ARCH="`get_config_var host`" || exit 4 ; }
VERSION=`
- sed -n 's/^AC_INIT([ ]*emacs[ ]*,[ ]*\([^ ),]*\).*/\1/p' <$SRC/configure.ac
+ sed -n 's/^AC_INIT([ ]*\[*emacs]*[ ]*,[ ]*\[*\([^] ),]*\).*/\1/p' <$SRC/configure.ac
` || exit 4
test -n "$VERSION" || VERSION=`
- sed -n 's/^AC_INIT([ ]*GNU Emacs[ ]*,[ ]*\([^ ),]*\).*/\1/p' <$SRC/configure.ac
+ sed -n 's/^AC_INIT([ ]*\[*GNU Emacs]*[ ]*,[ ]*\[*\([^] ),]*\).*/\1/p' <$SRC/configure.ac
` || exit 4
test -n "$VERSION" || { printf '%s\n' >&2 "$me: no version in configure.ac"; exit 4; }