summaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2020-12-18 09:38:29 -0500
committerEli Zaretskii <eliz@gnu.org>2020-12-18 09:38:29 -0500
commit48b9c47805fc304441017f6ee4c114212cdb0496 (patch)
treec12e4e5feb221bdd3f2de31af2e6a1c31eb1d712 /admin
parentd7a4ceaa1e5d347e84d99c6b854b2144b32366b3 (diff)
downloademacs-48b9c47805fc304441017f6ee4c114212cdb0496.tar.gz
Minor fixes in authors.el and in tarball-making instructions
* admin/authors.el (authors): Make the error message more helpful. (authors-ignored-files, authors-renamed-files-alist): Update.
Diffstat (limited to 'admin')
-rw-r--r--admin/authors.el18
-rw-r--r--admin/make-tarball.txt25
2 files changed, 34 insertions, 9 deletions
diff --git a/admin/authors.el b/admin/authors.el
index a418efea44f..f06b2129bfe 100644
--- a/admin/authors.el
+++ b/admin/authors.el
@@ -467,7 +467,12 @@ Changes to files matching one of the regexps in this list are not listed.")
"notes/font-backend"
;; ada-mode has been deleted, now in GNU ELPA
"ada-mode.texi"
+ "doc/misc/ada-mode.texi"
+ "lisp/progmodes/ada-mode.el"
+ "lisp/progmodes/ada-prj.el"
+ "lisp/progmodes/ada-xref.el"
"GNUS-NEWS"
+ "etc/GNUS-NEWS"
"doc/misc/gnus-news.el"
"src/fingerprint-dummy.c"
"src/fingerprint.h"
@@ -875,6 +880,7 @@ Changes to files in this list are not listed.")
"lisp/obsolete/spell.el"
"lisp/obsolete/swedish.el"
"lisp/obsolete/sym-comp.el"
+ "obsolete/sym-comp.el"
"library-of-babel.org"
"flymake-elisp.el"
"flymake-ui.el"
@@ -994,7 +1000,8 @@ in the repository.")
("nxml/test.invalid.xml" . "test-invalid.xml")
("nxml/test.valid.xml" . "test-valid.xml")
("automated/Makefile.in" . "test/Makefile.in")
- ("test/rmailmm.el" . "rmailmm.el")
+ ("test/rmailmm.el" . "test/manual/rmailmm.el")
+ ("rmailmm.el" . "test/manual/rmailmm.el")
;; The one in lisp is eshell/eshell.el.
("eshell.el" . "eshell-tests.el")
("automated/eshell.el" . "eshell-tests.el")
@@ -1118,8 +1125,11 @@ in the repository.")
("lisp/net/starttls.el" . "lisp/obsolete/starttls.el")
("url-ns.el" . "lisp/obsolete/url-ns.el")
("gnus-news.texi" . "doc/misc/gnus.texi")
- ("lisp/multifile.el". "lisp/fileloop.el")
- ("lisp/emacs-lisp/thread.el". "lisp/thread.el")
+ ("lisp/multifile.el" . "lisp/fileloop.el")
+ ("lisp/emacs-lisp/thread.el" . "lisp/thread.el")
+ ("lisp/emacs-lisp/cl.el" . "lisp/emacs-lisp/cl-lib.el")
+ ("lisp/progmodes/mantemp.el" . "lisp/obsolete/mantemp.el")
+ ("sysdep.c" . "src/sysdep.c")
)
"Alist of files which have been renamed during their lifetime.
Elements are (OLDNAME . NEWNAME).")
@@ -1593,7 +1603,7 @@ and a buffer *Authors Errors* containing references to unknown files."
;; the versioned ChangeLog.N rather than the unversioned ChangeLog.
(zerop (call-process "make" nil nil nil
"-C" root "change-history-nocommit"))
- (error "Problem updating ChangeLog"))
+ (error "Problem updating ChangeLog, try \"C-u M-x authors RET\""))
(let ((logs (process-lines find-program root "-name" "ChangeLog*"))
(table (make-hash-table :test 'equal))
(buffer-name "*Authors*")
diff --git a/admin/make-tarball.txt b/admin/make-tarball.txt
index 2c81a49e096..5125086e881 100644
--- a/admin/make-tarball.txt
+++ b/admin/make-tarball.txt
@@ -33,17 +33,32 @@ General steps (for each step, check for possible errors):
or some form of "git clean -x". It's probably simpler and safer to
make a new working directory exclusively for the release branch.
+ Make sure the tree is built, or at least configured. That's
+ because some of the commands below run Make, so they need
+ Makefiles to be present.
+
2. Regenerate the etc/AUTHORS file:
M-: (require 'authors) RET
M-x authors RET
(This first updates the current versioned ChangeLog.N)
- If there is an "*Authors Errors*" buffer, address the issues.
- If there was a ChangeLog typo, fix the relevant entry.
- If a file was deleted or renamed, consider adding an appropriate
- entry to authors-ignored-files, authors-valid-file-names, or
- authors-renamed-files-alist.
+ If this says "Problem updating ChangeLog", find the reason for the
+ failure of the command it runs, viz.:
+
+ make -C ROOT change-history-nocommit
+
+ (where ROOT is the top-level directory where you run this). It
+ could be because there are uncommitted changes in ChangeLog.N, for
+ example. One possible way forward is to invoke "C-u M-x authors",
+ which will skip updating the versioned ChangeLog.N file.
+
+ After "M-x authors" finishes, if there is an "*Authors Errors*"
+ buffer, address the issues. If there was a ChangeLog typo, fix
+ the relevant entry. If a file was deleted or renamed, consider
+ adding an appropriate entry to variables authors-ignored-files,
+ authors-valid-file-names, or authors-renamed-files-alist in
+ authors.el.
If necessary, repeat 'C-u M-x authors' after making those changes.
Save the "*Authors*" buffer as etc/AUTHORS.