summaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2016-04-13 11:12:15 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2016-04-13 11:12:39 -0700
commit1aebe99145e9ef612cdb272800904e3ba9297196 (patch)
treeadff82b1ea3fc1406907a1fb561e84d8d9a9dd9a /autogen.sh
parent7d835d8e792664e201ec50ba5f0a260d91e1fff5 (diff)
downloademacs-1aebe99145e9ef612cdb272800904e3ba9297196.tar.gz
Do not require that .git be a directory
Problem reportyed by Phillip Lord. * admin/update_autogen, autogen.sh, build-aux/gitlog-to-emacslog: * configure.ac, make-dist: Do not require that .git be a directory, as 'git worktree' makes it a file and not a directory.
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/autogen.sh b/autogen.sh
index 904246509fa..2e10a77cb37 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -330,7 +330,7 @@ fi
if test ! -f configure; then
echo "You can now run '$0 autoconf'."
-elif test -d .git && test $git_was_ok = false && test $do_git = false; then
+elif test -e .git && test $git_was_ok = false && test $do_git = false; then
echo "You can now run '$0 git'."
elif test ! -f config.status ||
test -n "`find src/stamp-h.in -newer config.status`"; then