summaryrefslogtreecommitdiff
path: root/config.bat
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2010-03-27 13:49:18 +0300
committerEli Zaretskii <eliz@gnu.org>2010-03-27 13:49:18 +0300
commit2201e7e2be76f3b03746d530059c8544a26a1036 (patch)
tree32ac47d4825e45fb11f0d6bf5eaefa43771cff07 /config.bat
parent5b5922f52f14c5be99126a9a590220a0de2c8e59 (diff)
downloademacs-2201e7e2be76f3b03746d530059c8544a26a1036.tar.gz
Fix the MSDOS build as fallout from the latest Makefile.in changes.
config.bat <lib-src>: Edit out lines that begin with several # characters. msdos/sedlisp.inp (VPATH): Don't edit, no longer needed. (lisp, srcdir): Adapt to lisp/Makefile.in changes. (abs_top_builddir): New edit. msdos/sed3v2.inp (KRB4LIB, DESLIB, KRB5LIB, CRYPTOLIB, COM_ERRLIB) (LIBHESIOD, LIBRESOLV, LIBS_MAIL): Edit to empty values. msdos/sed3.inp (KRB4LIB, DESLIB, KRB5LIB, CRYPTOLIB, COM_ERRLIB) (LIBHESIOD, LIBRESOLV, LIBS_MAIL): Edit to empty values. msdos/sed1v2.inp (abs_builddir): Edit into "../src".
Diffstat (limited to 'config.bat')
-rw-r--r--config.bat2
1 files changed, 1 insertions, 1 deletions
diff --git a/config.bat b/config.bat
index f2eb0262e60..5a0e9168fa3 100644
--- a/config.bat
+++ b/config.bat
@@ -222,7 +222,7 @@ rem ----------------------------------------------------------------------
Echo Configuring the library source directory...
cd lib-src
rem Create "makefile" from "makefile.in".
-sed -e "1,/== start of cpp stuff ==/s@^#[ ].*$@@" <Makefile.in >junk.c
+sed -e "1,/== start of cpp stuff ==/s@^##*[ ].*$@@" <Makefile.in >junk.c
gcc -E -traditional -I. -I../src junk.c | sed -e "s/^ / /" -e "/^#/d" -e "/^[ ]*$/d" >makefile.new
If "%DJGPP_VER%" == "2" goto libsrc-v2
sed -f ../msdos/sed3.inp <makefile.new >Makefile