summaryrefslogtreecommitdiff
path: root/config.bat
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2010-05-17 19:44:07 -0700
committerGlenn Morris <rgm@gnu.org>2010-05-17 19:44:07 -0700
commit40dc6bf44ec6e258dabd6aa3c674f8e65ded64bb (patch)
tree2fd6c610f4a8a842abc4816dbdd87ff35949e959 /config.bat
parentbe4ff9dad8bf43251f78f58a9ce86cf8bb153300 (diff)
downloademacs-40dc6bf44ec6e258dabd6aa3c674f8e65ded64bb.tar.gz
Set rallocobj with configure, not cpp.
* configure.in (REL_ALLOC): Unset on gnu, gnu-linux if DOUG_LEA_MALLOC. (RALLOC_OBJ): New output variable. * config.bat (RALLOC_OBJ): Edit to empty if sys_malloc. * src/Makefile.in (RALLOC_OBJ): New, set by configure. (rallocobj): Replace with the previous variable. (otherobj): Use $RALLOC_OBJ. * src/s/gnu.h (REL_ALLOC) [DOUG_LEA_MALLOC]: * src/s/gnu-linux.h (REL_ALLOC) [DOUG_LEA_MALLOC]: Move undef to configure. * msdos/sed1v2.inp (RALLOC_OBJ): Edit to ralloc.o.
Diffstat (limited to 'config.bat')
-rw-r--r--config.bat5
1 files changed, 3 insertions, 2 deletions
diff --git a/config.bat b/config.bat
index 35fef44b582..20b8b285e59 100644
--- a/config.bat
+++ b/config.bat
@@ -203,8 +203,9 @@ rm -f makefile.tmp
if "%sys_malloc%" == "" goto src5a
sed -e "/^GMALLOC_OBJ *=/s/gmalloc.o//" <Makefile >makefile.tmp
-sed -e "/^VMLIMIT_OBJ *=/s/vm-limit.o//" <makefile.tmp >Makefile
-rm -f makefile.tmp
+sed -e "/^VMLIMIT_OBJ *=/s/vm-limit.o//" <makefile.tmp >makefile.tmp2
+sed -e "/^RALLOC_OBJ *=/s/ralloc.o//" <makefile.tmp2 >Makefile
+rm -f makefile.tmp makefile.tmp2
:src5a
if "%nodebug%" == "" goto src6