summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMattias EngdegÄrd <mattiase@acm.org>2024-03-30 15:13:24 +0100
committerMattias EngdegÄrd <mattiase@acm.org>2024-03-30 15:19:56 +0100
commit1135ce461d188869e0294af45641edc2cbfacbf0 (patch)
treefe0c7ec4113ac62c6ab0d28b9bc8bc81dc005906 /configure.ac
parent890edfd2bb8fd79730919972cc82811b73c7f572 (diff)
downloademacs-1135ce461d188869e0294af45641edc2cbfacbf0.tar.gz
Always enable native JSON support and remove Jansson references
* src/json.c (Fjson__available_p): Remove. * lisp/subr.el (json-available-p): Always return t. * admin/nt/dist-build/build-dep-zips.py: * configure.ac: * doc/lispref/text.texi (Parsing JSON): * java/INSTALL: * java/org/gnu/emacs/EmacsNative.java (EmacsNative): * lisp/term/w32-win.el (dynamic-library-alist): * m4/ndk-build.m4 (ndk_INIT): * msdos/sed1v2.inp: * nt/INSTALL: * nt/INSTALL.W64: * src/Makefile.in: * src/emacs.c (main): * src/lisp.h: Remove JSON configuration options and references to it and Jansson from documentation and build files. * etc/NEWS: Announce.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 1 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index bd678ea52a3..b1dbaa13155 100644
--- a/configure.ac
+++ b/configure.ac
@@ -548,7 +548,6 @@ OPTION_DEFAULT_OFF([cairo-xcb], [use XCB surfaces for Cairo support])
OPTION_DEFAULT_ON([xml2],[don't compile with XML parsing support])
OPTION_DEFAULT_OFF([imagemagick],[compile with ImageMagick image support])
OPTION_DEFAULT_ON([native-image-api], [don't use native image APIs (GDI+ on Windows)])
-OPTION_DEFAULT_IFAVAILABLE([json], [compile with native JSON support])
OPTION_DEFAULT_IFAVAILABLE([tree-sitter], [compile with tree-sitter])
OPTION_DEFAULT_ON([xft],[don't use XFT for anti aliased fonts])
@@ -1216,7 +1215,6 @@ package will likely install on older systems but crash on startup.])
passthrough="$passthrough --with-png=$with_png"
passthrough="$passthrough --with-webp=$with_webp"
passthrough="$passthrough --with-gif=$with_gif"
- passthrough="$passthrough --with-json=$with_json"
passthrough="$passthrough --with-jpeg=$with_jpeg"
passthrough="$passthrough --with-xml2=$with_xml2"
passthrough="$passthrough --with-sqlite3=$with_sqlite3"
@@ -1305,7 +1303,6 @@ if test "$ANDROID" = "yes"; then
with_png=no
with_webp=no
with_gif=no
- with_json=no
with_jpeg=no
with_xml2=no
with_sqlite3=no
@@ -4005,27 +4002,6 @@ fi
AC_SUBST([LIBSYSTEMD_LIBS])
AC_SUBST([LIBSYSTEMD_CFLAGS])
-HAVE_JSON=no
-JSON_OBJ=
-
-if test "${with_json}" != no; then
- EMACS_CHECK_MODULES([JSON], [jansson >= 2.7],
- [HAVE_JSON=yes], [HAVE_JSON=no])
- if test "${HAVE_JSON}" = yes; then
- AC_DEFINE([HAVE_JSON], [1], [Define if using Jansson.])
- JSON_OBJ=json.o
- fi
-
- # Windows loads libjansson dynamically
- if test "${opsys}" = "mingw32"; then
- JSON_LIBS=
- fi
-fi
-
-AC_SUBST([JSON_LIBS])
-AC_SUBST([JSON_CFLAGS])
-AC_SUBST([JSON_OBJ])
-
HAVE_TREE_SITTER=no
TREE_SITTER_OBJ=
NEED_DYNLIB=no
@@ -5470,11 +5446,6 @@ case $with_gnutls,$HAVE_GNUTLS in
*) MISSING="$MISSING gnutls"
WITH_IFAVAILABLE="$WITH_IFAVAILABLE --with-gnutls=ifavailable";;
esac
-case $with_json,$HAVE_JSON in
- no,* | ifavailable,* | *,yes) ;;
- *) MISSING="$MISSING json"
- WITH_IFAVAILABLE="$WITH_IFAVAILABLE --with-json=ifavailable";;
-esac
case $with_tree_sitter,$HAVE_TREE_SITTER in
no,* | ifavailable,* | *,yes) ;;
*) MISSING="$MISSING tree-sitter"
@@ -7655,7 +7626,7 @@ Configured for '${canonical}'.
optsep=
emacs_config_features=
for opt in ACL BE_APP CAIRO DBUS FREETYPE GCONF GIF GLIB GMP GNUTLS GPM GSETTINGS \
- HARFBUZZ IMAGEMAGICK JPEG JSON LCMS2 LIBOTF LIBSELINUX LIBSYSTEMD LIBXML2 \
+ HARFBUZZ IMAGEMAGICK JPEG LCMS2 LIBOTF LIBSELINUX LIBSYSTEMD LIBXML2 \
M17N_FLT MODULES NATIVE_COMP NOTIFY NS OLDXMENU PDUMPER PGTK PNG RSVG SECCOMP \
SOUND SQLITE3 THREADS TIFF TOOLKIT_SCROLL_BARS TREE_SITTER \
UNEXEC WEBP X11 XAW3D XDBE XFT XIM XINPUT2 XPM XWIDGETS X_TOOLKIT \
@@ -7731,7 +7702,6 @@ AS_ECHO([" Does Emacs use -lXaw3d? ${HAVE_XAW3D
Does Emacs use -lotf? ${HAVE_LIBOTF}
Does Emacs use -lxft? ${HAVE_XFT}
Does Emacs use -lsystemd? ${HAVE_LIBSYSTEMD}
- Does Emacs use -ljansson? ${HAVE_JSON}
Does Emacs use -ltree-sitter? ${HAVE_TREE_SITTER}
Does Emacs use the GMP library? ${HAVE_GMP}
Does Emacs directly use zlib? ${HAVE_ZLIB}