summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrea Corallo <akrl@sdf.org>2020-11-14 22:07:54 +0100
committerAndrea Corallo <akrl@sdf.org>2020-11-14 22:07:54 +0100
commit2a8bf2222dd5d786375c131aa13dd1ea6f0cf104 (patch)
tree4f69d049302a8144783ff697f6a73d7e3e585539 /configure.ac
parentf702426780475309bdd33ef896d28dd33484246b (diff)
parentad29bc74ca9d4e1768698d4002b49c234624e359 (diff)
downloademacs-2a8bf2222dd5d786375c131aa13dd1ea6f0cf104.tar.gz
Merge remote-tracking branch 'savannah/master' into dev
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 11 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 100fbba06c9..e3a96a2b696 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3447,16 +3447,17 @@ else # "${HAVE_X11}" != "yes"
fi # "${HAVE_X11}" != "yes"
HAVE_HARFBUZZ=no
+### On MS-Windows we use hb_font_get_nominal_glyph, which appeared
+### in HarfBuzz version 1.2.3
+if test "${HAVE_W32}" = "yes"; then
+ harfbuzz_required_ver=1.2.3
+else
+ harfbuzz_required_ver=0.9.42
+fi
if test "${HAVE_X11}" = "yes" && test "${HAVE_FREETYPE}" = "yes" \
|| test "${HAVE_W32}" = "yes"; then
if test "${with_harfbuzz}" != "no"; then
- ### On MS-Windows we use hb_font_get_nominal_glyph, which appeared
- ### in HarfBuzz version 1.2.3
- if test "${HAVE_W32}" = "yes"; then
- EMACS_CHECK_MODULES([HARFBUZZ], [harfbuzz >= 1.2.3])
- else
- EMACS_CHECK_MODULES([HARFBUZZ], [harfbuzz >= 0.9.42])
- fi
+ EMACS_CHECK_MODULES([HARFBUZZ], [harfbuzz >= $harfbuzz_required_ver])
if test "$HAVE_HARFBUZZ" = "yes"; then
AC_DEFINE(HAVE_HARFBUZZ, 1, [Define to 1 if using HarfBuzz.])
### mingw32 and Cygwin-w32 don't use -lharfbuzz, since they load
@@ -6026,9 +6027,9 @@ fi
if test "${HAVE_CAIRO}" = "yes" && test "${HAVE_HARFBUZZ}" = no; then
AC_MSG_WARN([This configuration uses the Cairo graphics library,
- but not the HarfBuzz font shaping library. We recommend the use
- of HarfBuzz when using Cairo, please install HarfBuzz development
- packages.])
+ but not the HarfBuzz font shaping library (minimum version $harfbuzz_required_ver).
+ We recommend the use of HarfBuzz when using Cairo, please install
+ appropriate HarfBuzz development packages.])
fi
# Let plain 'make' work.