summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrea Corallo <akrl@sdf.org>2021-02-26 20:11:31 +0100
committerAndrea Corallo <akrl@sdf.org>2021-02-26 20:11:31 +0100
commit42fc752a14b23be95f02b598930f13a96883d3a0 (patch)
tree483070c09fbcca05d10460b9e220ef359072473d /configure.ac
parentb84c1727ea035cd47ab9ac5cb6627d402896f21d (diff)
downloademacs-42fc752a14b23be95f02b598930f13a96883d3a0.tar.gz
* Change native compiler configure flag into '--with-native-compilation'
* configure.ac: Rename configure nativecomp flags into --with-native-compilation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index fe0dc921dce..3dff9ea2e2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -484,7 +484,7 @@ OPTION_DEFAULT_ON([gnutls],[don't use -lgnutls for SSL/TLS support])
OPTION_DEFAULT_ON([zlib],[don't compile with zlib decompression support])
OPTION_DEFAULT_ON([modules],[don't compile with dynamic modules support])
OPTION_DEFAULT_ON([threads],[don't compile with elisp threading support])
-OPTION_DEFAULT_OFF([nativecomp],[compile with Emacs Lisp native compiler support])
+OPTION_DEFAULT_OFF([native-compilation],[compile with Emacs Lisp native compiler support])
AC_ARG_WITH([file-notification],[AS_HELP_STRING([--with-file-notification=LIB],
[use a file notification library (LIB one of: yes, inotify, kqueue, gfile, w32, no)])],
@@ -3786,7 +3786,7 @@ AC_DEFUN([libgccjit_not_found], [
AC_MSG_ERROR([elisp native compiler requested but libgccjit not found.
Please try installing libgccjit or similar package.
If you are sure you want Emacs compiled without elisp native compiler, pass
- --without-nativecomp
+ --without-native-compilation
to configure.])])
AC_DEFUN([libgccjit_dev_not_found], [
@@ -3808,7 +3808,7 @@ Here instructions on how to compile and install libgccjit from source:
HAVE_NATIVE_COMP=no
LIBGCCJIT_LIB=
-if test "${with_nativecomp}" != "no"; then
+if test "${with_native_compilation}" != "no"; then
if test "${HAVE_PDUMPER}" = no; then
AC_MSG_ERROR(['--with-nativecomp' requires '--with-dumping=pdumper'])
fi